0

After fresh install I updated my elementary os. It said that I have to reboot. I didn't. I installed my amd drivers and then I rebooted. I rebooted it myself I didn't clicked reboot.The e symbol appeared then dissapeared. And then my computer opened as a command line. There was no desktop. Help please !!

4
  • This is happening the second time.İ do t want to format my computer again. Jun 23, 2016 at 17:20
  • which graphic card do you have?, maybe is a problem with the proprietary driver
    – Alexandr
    Jun 23, 2016 at 17:34
  • İts the driver causing this i found but i dont know how to uninstall it Jun 23, 2016 at 19:24
  • İts amd crimson 15.12 graphics driver Jun 23, 2016 at 19:25

2 Answers 2

0

You need to uninstall the propietary driver and install back the open source driver, here are the steps: turn on the pc and wait until the command line is shown and put this:

sudo apt-get remove --purge xorg-driver-fglrx fglrx*
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo reconfigure xserver-xorg

put each command one by one (each line is a command). the first command will complety remove the propietary driver, the second reinstalls the open source driver and the third one reconfigure the system to use the driver open source.

All these steps are well docuemtned here, if you have a doubt you can check the link for more information

1
  • İ just uninstalled drivers and check the additional drivers part then reinstâll them. Jun 24, 2016 at 12:55
0

Try to restart lightdm deamon

sudo service lightdm stop
sudo service lightdm start

Come back and confirm if that did work for you.

18
  • 1
    İt says "stop" unknown instance Jun 23, 2016 at 17:28
  • so just punch in the second statement. The output signify that the daemon isn't running yet
    – zapper123
    Jun 23, 2016 at 17:32
  • Ok.But do i have to do this all the time? Jun 23, 2016 at 17:33
  • Uh oh.It seems like my computer froze at black screen ); Jun 23, 2016 at 17:36
  • Maybe your desktop environment would have failed initialization. I use to restart lightdm when my gui shell (Ctrl+Alt+F7) is frozen and rest ttys' work (Ctrl+Alt+F1-F6). Please confirm the persistance of the issue and meanwhile i might try to look into this closely. I currently have very less knowledge on lightdm service.
    – zapper123
    Jun 23, 2016 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.