I installed Master PDF editor from here, selecting the 64 bit .deb file. I installed it through the software center, and everything seemed to have been installed correctly, except that when I try to click its icon on the Applications menu the program doesn't start, nor does it start if I try to open a file with it; Gnome System Monitor doesn't show it anywhere, either. I tried purging and reinstalling, but nothing changed.

  • I had the same problem using Debian Jessie. Looked through Internet hoping to find any clue but so far none has proven to be useful or even slightly close to define what might be causing the problem.
    – user5656
    Jul 23, 2016 at 19:57
  • Are you on Freya or Loki?
    – wolf
    Oct 5, 2016 at 21:20
  • I'm having the same issue, tried downloading the qt4 version and it still does the same. I'm in Loki. I'm guessing we have to install some sort of qt libraries, but thats how far my knowledge goes. I have no idea of how we install qt libraries on elementary.
    – user7011
    Oct 20, 2016 at 10:11
  • Me the same after 2 years. I have install the 32bit version for Ubuntu, the application installed correctly but doesn't start :( Aug 28, 2018 at 4:19
  • I'm STILL having this problem and I unfortunately paid for the pro version of Master PDF Editor. It did work until recently. I'm using Arch Linux. I would love to see a resolution to this issue. Jun 24, 2020 at 19:52

2 Answers 2


There is a bug in the dependencies so there is a library missing (you can see this in the system log):

gnome-session[1630]: /opt/master-pdf-editor-3/masterpdfeditor3:
error while loading shared libraries: libQt5PrintSupport.so.5:
cannot open shared object file: No such file or directory

It might be a good idea to file a bug report but for now there is a workaround (in the terminal):

sudo apt install libqt5printsupport5 
  • The package is already install but the Master Pdf Editor still doesn't start. Aug 28, 2018 at 4:20
  • Having the same problem since the last two days. Unfortunately, running masterpdfeditor5 from the command line does not create any log entries.
    – mfg
    May 27, 2019 at 9:17

For me it was the package "libsane" missing.

After installing it, it started working on Jessie (using masterpdfeditor4 and installing "qt5-default" before masterpdfeditor4 .deb file via gdebi).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.