13

It always asks me to put a password in, but I think it is annoying: Is there a way to remove this?

I tried resetting the system settings, but that didn't work, I also tried to find it, but everything online says seahorse and I couldn't find that on elementary OS no matter how much I looked.

Just looking to change my keyring password or its settings, preferably remove some of them so I don't need to put my password in.

  • 1
    When exactly are you being asked for your password? – Lewis Goddard Jul 22 '15 at 21:34
  • when i log into geary, on a old install i didn't encrypt my pass word and it would never ask me to input the pass word for my key-ring, but now i am wondering if i can change the settings for my geary key-ring because the only solution i have is to format my drive or find the key-ring folder and delete it, but i ahhve no idea where that is. – gazny Jul 22 '15 at 22:59
  • Do you log on automatically? – Lewis Goddard Jul 23 '15 at 10:22
11

Option 1: Manage with Seahorse

Typically, matching your keyring password to your login password will unlock your keyring at logon (unless the logon is automatic). You can install the management application seahorse to modify your keyring password to match.

sudo apt install seahorse
seahorse

Option 2: Delete the Keyring

If you're not concerned about losing any existing saved passwords, you can just delete the keyring. The next time you are prompted to use it you can create a new one with a password that matches your logon.

rm ~/.local/share/keyrings/login.keyring
  • thanks, very interesting that they wouldnt have included this into elementary – gazny Jul 23 '15 at 16:08
  • 1
    I think the reason for not including it was it should all just work, but in your instance something has clearly gone awry and the tool is indeed useful to offer a fix. – Lewis Goddard Jul 23 '15 at 18:18
  • This happened to me on each system startup even with identical passes for keyring and login. (the window could be dismissed with Esc with no problem, I guess the keyring was empty anyway). Option 2 didn't change anything. (Re)matching default keyring passes with seahorse kept showing the pop-up. Completely deleting the default keyring in Seahorse solved it. – user170 Nov 28 '16 at 8:23
  • I'm pretty sure the reason my system got into this state was a) my password was too long (31 characters) so I shortened it, b) I didn't type what I thought I did, despite typing it the same way 2x, c) I had to boot from USB and enter maintenance mode to change my password. This (I went with option 2) did resolve the issue for me. – hlongmore Nov 17 '18 at 6:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.