Loki Beta running smoothly.

Unable to install Git- Tried with numerous methods no Luck.

I receive The following packages have unmet dependencies: git : Depends: liberror-perl but it is not installable E: Unable to correct problems, you have held broken packages

have tried the following to no avail. apt-get install -f sudo apt-get purge git sudo apt-get purge git-all sudo dpkg -r --force-all git apt-get install --reinstall git apt-get install perl sudo add-apt-repository ppa:git-core/ppa sudo dpkg --configure -a apt-get check apt-get -f install apt-get install liberror-perl apt-get autoremove dpkg --get-selections | grep hold sudo rm -rf /var/lib/apt/lists/* Guess what solved the solution. I'm a bloody idiot!

I'll leave this here , so If any one else has issues like this, the solution is so simple. So easily to over look.

As Loki is a beta, I did not check to see if ticked, "Software & updates", then "Ubuntu Software" tick box " Community maintained (Universal)" .

Then do the usuall stuff, as above. will fix the problem, unmet dependencies.

I hope this helps others !

closed as off-topic by lemonslice, png2378, Daniel Foré Dec 8 '16 at 6:49

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "The Question is about a release or feature that was in testing and is now released, hence the question is no longer applicable." – lemonslice, png2378, Daniel Foré
If this question can be reworded to fit the rules in the help center, please edit the question.

Guess what solved the solution. I'm a bloody idiot!

I'll leave this here , so If any one else has issues like this, the solution is so simple. So easily to over look.

As Loki is a beta, I did not check to see if ticked, "Software & updates", then "Ubuntu Software" tick box " Community maintained (Universal)" .

Then do the usuall stuff, as above. will fix the problem, unmet dependencies.

I hope this helps others !

Not the answer you're looking for? Browse other questions tagged or ask your own question.