I've been trying to make it boot from a flashable usb stick for 2 days and I still haven't managed to do so. I tried with many other linux distros (ubuntu, mint, debian, manjaro) and they all work fine. I used rufus to make a flashable usb stick.

When I try to boot it from the usb stick it just goes to the selection menu and when I click on either install or try elementary OS without installing, 2 lines of text appear in the left corner of the screen and disappear within ~1 second and then the screen just goes full black. I have secure boot disabled, fast boot disabled.

  • 1
    Add some more details please, like: which .iso are you using, which version of rufus are you using, have you tried some other USB iso burning tool, have you tried re-downloading the iso?
    – Gabriel
    Jun 13, 2016 at 19:43
  • Have you followed the instructions given here? elementary.io/en/docs/installation
    – Gabriel
    Jun 13, 2016 at 19:44
  • @Gabriel I tried to use other USB iso burning tools like UnetBootIn. I re-downloaded the iso 3 times and checked the SHA-256 to make sure it's correct. I'm using rufus 2.9.
    – proag
    Jun 13, 2016 at 19:58
  • @Gabriel I followed the given instructions, I just don't know where I fail, I also tried to use other usb stick but with no success.
    – proag
    Jun 13, 2016 at 20:01
  • Try with nomodeset option.
    – Aleksandar
    Jul 29, 2016 at 5:43

4 Answers 4


I had similar problems: When getting to the boot launcher where you choose what to boot, you can press 'e' to edit the actual boot command. Add 'nomodeset' after 'quiet splash' and prior to the '--' near the end of the line.


Try re-downloading the .iso through magnet link (or directly) cross-reference the sha256.

if everything checks out, format your usb as fat32 with default allocation (or I usually prefer 32kb)

Open rufus and select your drive, and iso as normal and make sure to ONLY do those things, don't change any other settings.

If this doesn't work, redownload rufus as a portable version and use that (to ensure that no settings have been changed).


i have more than couple of install this works for me almost every time . -format the usb to fat32 . -you can use the dd command the if you are using already using a nix system already eg of dd command : sudo dd if=/path/to/.iso of=/dev/sdb bs=1M

try booting . if this doesn't work try unetbootin, or startup disk creator , this might help you https://elementary.io/es/docs/installation#verify-your-download

or try with a different memory stick


If you have thinkpad go to bios and change "hybrid graphics" to "discrete graphics".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.