I have the same problems that several people had before. Wifi ain't working.

However, installing the libnl-3-200 libnl-route-3-200 and libnl-genl-3-200 did not work, nor did downgrading.

At first it worked, however, after a reboot it stopped working again (not after the one immediately after the reinstallation but after the weekend ...) So I tried to fix it again, downgrading etc. Installing the libnl-* files did neither work using apt-get nor work by doing so manually. After hours of doing so I got frustrated and reinstalled elementaryOS for the first time. Again non aforementioned ways of fixing WiFi worked... after another hour of trying all fixes I could think of I'm now in the process of reinstalling it again (first time with active Ethernet ... )

Can anyone point out another way of fixing the WiFi

If you need any information to help me, please say so and I will do my best to deliver that info.


1 Answer 1


You might be missing the b43 firmware drivers.

Open terminal and check your Wireless card model

lshw -C network

For models: * BCM4306/3; * BCM4311; * BCM4318; * BCM4321; * BCM4322 (only 14e4:432b); * BCM4312 (with Low-Power a.k.a. LP-PHY).

Install with sudo apt install firmware-b43-installer

For models: * BCM4301; * BCM4306/2; * BCM4306.

Install with sudo apt install firmware-b43legacy-installer

  • The BCMx number does not really matter apparently. If you do lspci -vvnn | grep 14e4, you should pay attention to the number behind 14e4. For example: BCM4321 has 2 drivers. 4328 has b43 and 4329 has bcmwl-kernel-source. The following webpage also has a nice table of support: linuxwireless.org/en/users/Drivers/b43
    – John K
    Commented Aug 10, 2016 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.