1

I'd like to install VMware Player on Freya, but got the following error:

sam@samlaptop:~/Downloads$ sudo ./VMware-Player-4.0.6-1035888.x86_64.bundle
Extracting VMware Installer...done.
Gtk-Message: Failed to load module "canberra-gtk-module"
Attempt to unlock mutex that was not locked
/tmp/vmis.C8OWKd/install/vmware-installer/vmware-installer: line 22: 9093 Aborted (core dumped) VMWARE_INSTALLER="$VMWARE_INSTALLER" VMISPYVERSION="$VMISPYVERSION" "$VMWARE_INSTALLER"/vmis-launcher "$VMWARE_INSTALLER"/vmware-installer.py "$@"
1

Module libcanberra is obviously missing.

Install the module using following command:

# sudo apt-get install libcanberra-gtk-module

Or if it's already installed and you still get the error it would mean x86 version is needed for compatibility, but it's missing. Install x86 version using following command:

# sudo apt-get install libcanberra-gtk-module:i386
1

Is there any reason why you use version 4.x? There is VMware Player 7.x available. Maybe the current version does not make problems. Some months ago I had problems with VMware Workstation and found my solution on askubuntu:

https://askubuntu.com/questions/449629/error-installing-vmware-workstation-on-ubuntu

I would give version 7 a try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy