0

I pretty much just want to ask this exact question: askubuntu forum only for elementary (freya). I cant figure out how to do it with the normal network settings.

As the solution in the askubuntu forum proposed, I was searching for an option called Band. However I cant find any options in the Network settings, that adjust the frequency, as I wish. Or I just cant recognize it as one.

  • 1
    I noticed this question didn't gather much attention here. For future reference, consider posting on askubuntu if unsuccessful here, simply because Elementary uses Ubuntu as a base. Freya in specific is based on the 14.04 LTS release. Most (if not all) of what applies to Ubuntu applies to Elementary, at least at the kernel level. In the meantime, I've posted an answer below. – ThisIsNotAnId Jan 27 '17 at 22:57
1

Run lshw -class network. Look at the logical name for your wireless card. Let that be denoted <wlan>. CD into a relevant directory, store your current wireless config: iwconfig <wlan> > current_wireless_config to restore settings later if need be.

Post the output to iwlist <wlan> channel here. You may wish to follow the advice in this answer: https://askubuntu.com/a/55748 or you may download linSSID from the app center and find a good open channel and frequency and set it as follows.

Turn your wifi off, then run:

sudo iwconfig <wlan> mode Managed
sudo iwconfig <wlan> freq <desired-freq>
sudo iwconfig <wlan> channel <desired-channel>

Make sure this is in agreement with your output from iwlist <wlan> scan or iwlist <wlan> channel and the frequency matches the corresponding channel. Reboot computer.

WARNING: According to man iwconfig under "freq/channel":

When using Managed mode, most often the Access Point dictates the channel and the driver may refuse the setting of the frequency.

As per your discussion on askubuntu, Managed mode may be the best option you have. So try just that without changing the frequency or channel parameters and see how it goes.

Other parameters of your wireless interface may also be the culprit for your connectivity issues. To be sure, post the output to iwconfig <wlan> in your question.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.