0

I install elementary os on Lenovo Ideapad Y700. the laptop run before with win 10 and every thing work fine. after installing elementary os the system doesn't identify the WiFi but its let me to connect with wire connection.

whats i'm doing wrong or how can i define my wifi?

I used elementary os on old lenvovo laptop and it's identify the WiFi automatically with no problem.

the spec of the computer: Processor---------6th Generation Intel® Quad-Core i7 Processor Discrete Graphics---------NVIDIA® GTX 960M 4 GB GDDR5 Memory---------16 GB DDR4 Webcam---------HD 720p, 2 x Internal Digital Array Microphone, or Intel 3D RealSense Camera (Optional)

Storage --------- 128 ssd with 1 TB HDD Audio--------- 2 x 2W JBL Speakers with Chamber + 3.0 W Subwoofer and Dolby® Home Theater™ Battery --------- 4 Cell 60 WHr Keyboard--------- Red LED Backlit with 2 Level Brightness Control Display --------- Frameless Full HD (1920 x 1080) or Ultra HD (3840 x 2160) 16:9 IPS Anti-Glare Dimensions

(inches) : 15.23" x 10.90" x 1.02"
(mm) : 387 x 277 x 25.95

ODD--------- Optional External USB 2.0 DVD/BD Tray-In

WLAN--------- LAN 1000 M, Up to WiFi 2 x 2 a/c + Bluetooth® 4.0 Ports--------- 2 x USB 3.0, 1 x USB 2.0 + Always-on, DC-in, 2-in-1 Audio Combo Jack, 1 x HDMI, 1 x 4-in-1 Media Card Reader (SD, SDHC, SDXC, MMC)

1

The elementary kernel doesn't have the correct (new) drivers for Skylake (6th gen. ix) machines. On the other hand the newest kernels gave me other glitches / incompatibilities with elementary. Kernel 4.2.8 and following ckt versions do the job for me. Intel graphics then still also need some tweaking: You should add i915.preliminary_hw_support=1 to grub to get hardware accelleration from the Intel GPU as well. http://www.phoronix.com/scan.php?page=news_item&px=intel-skl-prelim-support

Google "elementary OS Skylake" for all info on the broader subject. I run elementary OS on an Intel NUC6i3 (also Skylake) and also had to work through these issues. Everything runs super stable and snappy fast now.

0

I have similar problem, every time I turn on elementary OS (or any other Linux distribution) I can't connect to Wifi, but when I put it on sleep then turn it on again, it connects to Wifi then. Try first that, and if it doesn't work, try Alex's method.

0

Thank for the answers. I use this solution for my problem and it's work well http://www.everydaylinuxuser.com/2016/05/fixing-linux-mint-wireless-issues-on.html

Now I have anther issues with my graphic card and some reboot problems like after reboot I get black screen or after update when i press restart the system freeze

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.