I want to install some opentype .otf fonts, that worked perfectly on my former ubuntu os. I copied them to


like described in previous questions, which seems to work – they are displayed in fontlist in e.g. libre office now.

But the typefaces are not displayed correctly, they either change to a default font or show only placeholder glyphs. I've already tried installing libotf-bin

apt-get install libotf-bin

but still they cannot be displayed. somehow elementary doesn't know the file format and doesn't support .otf ?? can anyone help me out on this one? thank you!

I'm using Elementary OS 0.3.2 Freya (64bit)

  • I tried installing the fonts locally and not in root. Now they work and are displayed correctly. I had to create folder ~/.fonts since it didn't exist yet and simply copied the folders containing .otf-fonts with files-browser to ~/.fonts
    – mscot
    Commented Jun 6, 2016 at 12:32

2 Answers 2


some times the permissions in the files are wrong, if you install the font in "/usr/share/fonts/" you need to check the file permission to ensure that all the users can read the font file refresh the font cache and that's all, this is only when you want to install a font that can be used by all the users in the pc, but if you want the font only for your user just open.otf file whit the font viewer and select the option install.


For personal use

TTF files in ~/.local/share/fonts/truetype (old way was ~/.fonts/truetype)

OTF files in ~/.local/share/fonts/type1 (old way was ~/.fonts/type1)

For system wide use

TTF files in /usr/local/share/fonts/truetype

OTF files in /usr/local/share/fonts/type1

Then sudo fc-cache and you should see the fonts.

An alternative way is to place fonts generally in ~/.local/share/fonts/ (old way was ~/.fonts/).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.