11

I am trying to use the FiraMono font. I downloaded the .otf files and saved it in the ~/.fonts directory and also ran fc-cache -vf ~/.fonts to update the cache.

Now, when I open elementary tweaks, I don't see it listed in the fonts. What am I missing?

  • Have you tried sudo fc-cache ...? – bigbang Jul 22 '15 at 6:18
  • Yes, I did. Still no luck. – sabman Jul 22 '15 at 18:05
  • try the default font viewer and install the font through clicking install – Aditya ultra Jul 23 '15 at 13:50
12

They should be placed in the following folders

For personal use

TTF files in ~/.local/share/fonts/truetype (old way was ~/.fonts/truetype)

OTF files in ~/.local/share/fonts/type1 (old way was ~/.fonts/type1)

For system wide use

TTF files in /usr/local/share/fonts/truetype

OTF files in /usr/local/share/fonts/type1

Then sudo fc-cache and you should see the fonts.

An alternative way is to place fonts generally in ~/.local/share/fonts/ (old way was ~/.fonts/).

Can you see the new fonts in Libre Office or similar office programs?

| improve this answer | |
  • I did not have the folders truetype and type1 under /usr/local/share/fonts/. I had to create the type1 folder and copied the otf files there. I did see the type1 and truetype folders in /usr/share/fonts/. I copied the otf files to that location as well. I did sudo fc-cache but still no luck. I do not have any office programs installed to try. Thanks for your response. – sabman Jul 22 '15 at 18:00
  • Just installed LibreOffice Writer and I don't see it listed in the fonts either. – sabman Jul 22 '15 at 18:12
  • This was perfect, thanks man! One thing I did was also ran sudo fc-cache -fv (i.e. with the f and v options) – Jay Mar 26 '16 at 19:14
  • Why do we have button Install when opening font and that says installed after opening font again and we're unable to see the installed fonts in that way? – Frankie Drake Jun 1 '17 at 19:04
3

TrueType fonts can be installed from file manager - double click the .ttf file, font manager will open, click "install".

To install multiple fonts system wide: ttf files:

$ sudo cp ./yourpath/*.ttf /usr/share/fonts/truetype/  

opentype:

sudo cp ./yourpath/*.otf /usr/share/fonts/opentype/

And then:

sudo fc-cache -fv
| improve this answer | |
1

I followed the instructions provided here. This is what I did to have it working.

Created the FiraSans directory in /usr/share/fonts/truetype

$ sudo mkdir -p /usr/share/fonts/truetype/FiraSans

Moved the ttf font files to that directory and then updated the cache

$ sudo fc-cache -f -v

Initially, I did try with the OTF files and later moved to TTF files. I don't think that made the difference but just FYI.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.