3

I'm having trouble with the Adobe Flash Plugin. Firefox, with which I substituted Midori, blocks it.

I have tried to re-install it from the software center, I have installed flashplugin-installer, I tried apt-get update & install. All with no success.

I'm wondering, might it be due to this?

Here a related post in SE Ubuntu.

Also I'm experiencing this same issue.

Any suggestion?

  • Mentioning your current version of Mozilla Firefox and Adobe Flash could be useful. – maliktunga Jul 22 '15 at 0:33
3

Fix your Sources

If you are seeing the “The update information is outdated.” warning, you should use the Software Updater to check for updates, and install any available. That should get rid of that warning, unless one of the sources you've added is unavailable or unverifiable. In that instance, you should remove the affected sources.

Flash is Dead

Since Flash is deprecated in Firefox and on Linux, I think it is safe to assume that regardless of whether it is a numbering issue or not, an official fix is not forthcoming. If you can, try to simply get by without it, or you can right click to allow always.

Alternatives

Gnash is a GNU alternative to Flash. It does not appear to be actively maintained.

LightSpark is another alternative, but one which appears to be reasonably well maintained.

  • Yes, some of my sources are broken. Regarding the Flash thing, do you know of any substitute? And what is the real risk when using it? – ZenoCosini Jul 21 '15 at 17:56
  • Generally the best substitute is usually HTML. YouTube have used HTML players as default for some time, people are usually surprised by how much works without it. I've added alternatives to my answer. – Lewis Goddard Jul 21 '15 at 18:48
1

Additional Alternatives

Lewis already mentioned Gnash and LightSpark. If you are a Firefox user I would suggest also keeping an eye on Mozillas Shumway project.

If you really really can't avoid using the proprietary version of flash (for sites utilising DRM etc.) the simplest way unfortunately is to use Google Chrome as it comes bundled with an up to date version maintained by Adobe/Google by way of a PPAPI plugin.

For those of us using browsers only supporting older NSAPI plugins (Firefox, Midori etc.) there is a wrapper for Googles plugin called Fresh Player Plugin. Installing it used to be rather difficult, though there are several PPAs including it nowadays.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.