1

The issue is as simple as that. I tried installing elementary OS on a Virtual Machine inside my Windows 8.1 installation and went "great"(meaning there was the usual Linux/VirtualBox issues but it installed and ran fine) so I made the move and created a bootable USB not with Rufus but with that other software suggested by Ubuntu itself, can't recall the name.

Well, I tried re-downloading the image and re-making the bootable USB already but it won't install on my Giada MiniPC for some reason... actually, it installs but there's only the wallpaper after first boot!

If I manually reboot it I get to the login and when I log there's the desktop alone again...tried having my Linux-savvy friend do something about it but it doesn't accept the common commands.

The cursor is there but there's really nothing at all aside from the desktop, why is that? The computer is this one: http://www.giadapc.com/products/minipc/slim%20series/i35B.html

EDIT I forgot to mention I thought about monitor/aspect ratio problems but I tried changing the monitor(I got a normal 22"something Fujitsu working great during installation) and even the cables from HDMI to VGA etc.

3

I found a blog post talking about your issue and it looks like - at least for them - it was possible to solve this with a boot option. I'm not exactly sure it will help you as well, but here is an answer how to set this boot option. If it does not work, just let me know and we'll figure this out in another way.

  1. Boot up your computer to the blank desktop and press Ctrl + Alt + F1. You will now see a terminal-based interface (black screen, white font).
  2. Log in with your username and your password. When typing in your password, it will not be displayed in any way, so that's expected behavior, don't be irritated.
  3. After the login, you run sudo nano /etc/default/grub (it will ask for your password again, because you are using sudo), which opens the texteditor nano to edit a file responsible for how GRUB (the bootloader) boots up your system. You can move the cursor of nano via the arrow keys.
  4. Find the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add nomodeset as option. The line should look like this now: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset".
  5. To save and leave nano press Ctrl + o first, press enter to confirm the file name, and press Ctrl + x afterwards to go back to the command line.
  6. Run sudo update-grub now to update the settings you just have changed.
  7. Run sudo reboot to reboot your system.

After the reboot, it should display your full desktop, including Wingpanel and Pantheon's dock. As said, if not, just let me know and we'll figure the issue out.

  • I'm testing this as soon as I get back to my office from launch, I'll update you and tell if it works or not. Meanwhile, thanks for clearing this up! I found that post but wasn't unsure how to operate! – daghene Jul 21 '15 at 10:43
  • if I press that combination of keys the computer freezes and I'm forced to reboot it :/ – daghene Jul 21 '15 at 12:29
  • Mh, you said you are able to login, so what does happen when you press the keys before logging in? Otherwise, press and hold "Shift" during early boot, you will see the boot menu. Press "e" on the default entry, look for quiet (the line starts with linux) and replace it with nomodeset. Press "F10" and try to do the steps above again. If that helps, I'll add it to the answer. – embik Jul 21 '15 at 12:36
  • Here I am! It all worked up until I changed "quiet" with "nomodeset". I pressed F10, it rebooted, I logged in and I tried to press Ctrl + Alt + F1 again and it still made my cursor disappear and blocked everything. Mouse didn't work, keyboard didn't work and the light on the front panel of the MiniPC turned off. It was still on, but it's like it's freezing. Right now I'm downloading Ubuntu/Xubuntu to try and see if it's the computer or the distro. – daghene Jul 22 '15 at 7:36
  • Tried Ubuntu and it's so slow the desktop is not even responding but at least the UI is there, I'm trying Xubuntu now because I start fearing it's lack of hardware more than the distro's issues. The non-appearing UI problem still says anyway. – daghene Jul 22 '15 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.