3

I performed a clean install of Elementary OS Freya just a couple of hours ago on a Lenovo G580 (20150) laptop (from which I'm now writing) with a brand new replacement HDD. For some reason, the battery utility detects the battery itself, but does not take readings of any kind.

So, what are my options for fixing this pesky issue?

Edit: [upower -d]

Device: /org/freedesktop/UPower/devices/line_power_ACAD
  native-path:          ACAD
  power supply:         yes
  updated:              21.07.2015 (вт) 15,31,55 EEST (1371 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    online:             yes

Device: /org/freedesktop/UPower/devices/battery_BAT1
  native-path:          BAT1
  vendor:               LENOVO
  model:                PABAS0241231
  serial:               41167
  power supply:         yes
  updated:              21.07.2015 (вт) 15,54,30 EEST (16 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               charging
    energy:              0 Wh
    energy-empty:        0 Wh
    energy-full:         0 Wh
    energy-full-design:  0 Wh
    energy-rate:         0 W
    percentage:          0%
    capacity:            100%
    technology:          lithium-ion

Daemon:
  daemon-version:  0.9.23
  can-suspend:     no
  can-hibernate:   no
  on-battery:      no
  on-low-battery:  no
  lid-is-closed:   no
  lid-is-present:  yes
  is-docked:       no

Final edit: [PROBLEM SOLVED]

The problem seems to have resolved itself! For the last few days I had been running off the charger, but the battery was plugged in too. When I plugged off the charger, the laptop shut down, which led me to believe it wasn't charging the battery. I removed the battery from its slot and inserted it again. That fixed the problem (though I have no idea why), since the menu bar now displays the charge percentage and it started from 1%, meaning the battery was completely empty before. (Laptop wasn't used for a month and a half prior to these events.) I hope this helps somebody experiencing the same problem. And just a few quick tips, which I already knew, but for some reason ignored:

1- Lithium ion batteries live longer if they aren't charged to 100% every time. About 60% will give you the longest life span.

2- Lithium ion batteries DEGRADE VERY FAST WHEN THEY ARE FULLY DISCHARGED. Don't let them stay below 10% capacity for a long time.

  • Would you mind to add the output of upower -d (it's a terminal command) to your post? As far as I know, the battery utility is based on that data. – embik Jul 21 '15 at 8:16
  • The problem resolved itself. – pdobrev Jul 21 '15 at 13:55
  • Great to hear! It would also be great if you could add your way of "solving" this problem as an answer, because it might help other people as well! – embik Jul 21 '15 at 14:02
  • This seems like a "wiggle it" scenario, where a dodgy connection was to blame more than elementary. – Lewis Goddard Jul 21 '15 at 18:58
  • Couldn't know at the time. The battery was flush in its slot, so it never occurred to me that it might be the root of the problem, given that it has worked perfectly fine for over three years now. – pdobrev Jul 27 '15 at 13:28