I have tried to download Freya on a Linux machine using Chrome and Firefox, I also tried to download it in Incognito / Private browser modes.

I have also tried on a Windows 7 machine using Chrome and Firefox. I did donate (twice) but when I click on download the screen goes grey.

Is this because I am trying to download from the UK? I see that the store only accepts US orders.

On an earlier question posted by someone else ( I am unable to download elementary OS ) you posted links to a direct download - I tried to follow them but got the message "405 Not Allowed".

  • I am flagging to close this question because it is about a temporary network outing and will not be useful to future visitors. – Gilles 'SO- stop being evil' Jul 20 '15 at 21:09

There is no regional restriction for downloading elementary OS and you can download elementary OS for free by typing in $0 in the "custom amount" field, you don't need to donate every time (although it's greatly appreciated, thank you very much).

That being said, the download doesn't start for me either. I'd assume there are some technical problems with elementary's download servers right now and this will be fixed as fast as possible.

edit: The web team worked on this issue and the download should be back up without problems (works again for me, at least).

Not the answer you're looking for? Browse other questions tagged or ask your own question.