9

My app launcher is quite full; Google Chrome adds a lot of apps to slingshot, and I don't use things such as the multitasking overview or the software centre. Is there any way I can hide these apps from view?

  • 1
    @Tim don't use slingshot to launch Chrome apps at all, that's always done through the browser itself. – Bill O'Dwyer Jun 30 '15 at 21:58
  • Just a little tip that could help someone else to avoids the mistake I just made : Type in "NoDisplay=true", because "...=True" won't work, it's case sensitive ! I changed a first time 25 .desktop files before realizing that! Have a good day, and I'm quite happy with Elementary, just want to point that out :-) – user3097 Nov 14 '15 at 7:17
  • Easiest way to do it is to install "AppEditor" from elementary's appstore. You will find all the options in there. – DanyGee Feb 18 '18 at 11:28
13

Delete web application desktop entries added by Chrome

to get rid of all web application entries, open a terminal session and run

rm ~/.local/share/applications/chrome-*.desktop

to delete only a few of them, you'll have to take a look inside of each file and delete only the ones you want get rid of.

Hide a desktop entry of a system application

if you want to hide an application like the multitasking overview, you have to copy it's .desktop file to your users local application folder:

cp /usr/share/applications/gala-multitaskingview.desktop ~/.local/share/applications

edit the copied file:

scratch-text-editor ~/.local/share/applications/gala-multitaskingview.desktop

and add the following line:

NoDisplay=true
  • This does not seem to work on 0.4 Loki. – raisinrising Oct 27 '16 at 13:03
  • @RuppalSingh it still works in Loki, but a more comfortable way to do this task is to install and use Menulibre. – Rafael Oct 27 '16 at 13:13
  • I have tried this on several icons that appear upon installing Calibre. None of them go away. I even have an ugly VIM icon I can't get rid of! Unless deleting the .desktop file is the only option... – raisinrising Oct 28 '16 at 4:55
  • @RuppalSingh you must be doing something wrong... I'm also hiding several Calibre icons and all of them disappear after adding NoDisplay=true. Please try using Menulibre, this application is self explanatory and it's a more convenient way to hide these icons. – Rafael Oct 28 '16 at 18:00
4

As you don't need to access them any more, you can remove the .desktop files from:

~/.local/share/applications

Anyway, to know what ones you want to remove, select them all and open properties. Then chose More and Click Execute, next to Owner and next to Group. The number should now be 774.

Their icons will change from the unknown file to the app logo:

Then you can delete the ones you no longer want.

0

There are two places where .desktop files get stored: /usr/share/applications/ (system-wide) and ~/.local/share/applications (specific to the current user). Slingshot looks at those .desktop places and shows them.

Default applications get stored in the system wide one. Google Chrome is using the place specific for the current user.

In both of the cases, you can delete the shortcut by typing:

rm NAME.desktop

If you want to delete system wide shortcuts, you'll have to use sudo in front of the command.

0

Disable the checkbox Applications menu when creating a Chrome application shortcut:

enter image description here

  • You don't think you can customise those, unfortunately. – orschiro Jul 1 '15 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.