When locked, my laptop (Ideapad Y510P, with proprietary Nvidia drivers installed) screen just turns off. The laptop is still on, but I cannot access the lock screen to unlock. The only thing I can do is push the power button, which will shutdown the system. I cannot access a tty, and is unresponsive. My GPU is a GT750M. Is there any way I can fix this?

  • Did this happen with the FOSS drivers as well? How did you install the proprietary nvidia drivers?
    – embik
    Commented Jul 19, 2015 at 18:46
  • This appear for me on t420 with loki too. With Logout.
    – vrcmr
    Commented Jul 11, 2017 at 9:25

2 Answers 2

  • Run sudo -i scratch-text-editor /etc/default/acpi-support

  • Find and change POST_VIDEO=true to POST_VIDEO=false

  • Find and change SAVE_VBE_STATE=true to SAVE_VBE_STATE=false

  • Restart your laptop, issue should be solved.

Source:Blog, Ubuntu Launchpad, Worked on mine.

  • This works under a certain condition for me. If I suspend the laptop at least once after it has been started up, then the lock screen issue does not come up. If this was not done, then I run into the same issue. Once I get the black lockscreen, the laptop is still running (the power light is one, and I can hear the fans), however I cannot suspend by closing the laptop lid. I can only shut it down using the power button. If I do happen to suspend at least once after start up, then the lock screen seems to work perfectly fine, no black screen.
    – Daichi
    Commented Jul 20, 2015 at 14:56
  • This worked for me. I'm running Advanced Micro Devices, Inc. [AMD/ATI] Oland [Radeon HD 8570 / R7 240/340 OEM] GPU in a Dell OptiPlex 9020
    – user4543
    Commented Mar 21, 2016 at 20:11

Alternately you can type the login password and click enter when you see the black screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.