3

I installed Freya 64-Bit on a Dell Latitude E6420. Everything seems to be working fine except for Brasero. Below is what I get if I try to run it via Terminal:

(brasero:10373): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-4ejj8DFSiS: Connection refused
(brasero:10373): Gtk-CRITICAL **: gtk_widget_get_preferred_width: assertion 'GTK_IS_WIDGET (widget)' failed
(brasero:10373): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion 'GTK_IS_WIDGET (widget)' failed
(brasero:10373): Gtk-CRITICAL **: gtk_widget_get_preferred_width: assertion 'GTK_IS_WIDGET (widget)' failed
(brasero:10373): Gtk-CRITICAL **: gtk_widget_get_preferred_width: assertion 'GTK_IS_WIDGET (widget)' failed
(brasero:10373): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion 'GTK_IS_WIDGET (widget)' failed
(brasero:10373): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion 'GTK_IS_WIDGET (widget)' failed
(brasero:10373): Gtk-CRITICAL **: gtk_widget_get_preferred_width: assertion 'GTK_IS_WIDGET (widget)' failed
(brasero:10373): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion 'GTK_IS_WIDGET (widget)' failed
(brasero:10373): Gtk-CRITICAL **: gtk_widget_get_preferred_width: assertion 'GTK_IS_WIDGET (widget)' failed
(brasero:10373): Gtk-CRITICAL **: _gtk_widget_get_preferred_size_and_baseline: assertion 'GTK_IS_WIDGET (widget)' failed
5

You can install a newer version of Brasero from the GNOME3 Staging PPA. It works fine without errors.

In a terminal, type:

sudo apt-add-repository ppa:gnome3-team/gnome3-staging
sudo apt-get update
sudo apt-get install brasero
sudo add-apt-repository --remove ppa:gnome3-team/gnome3-staging

Please note that you won't be able to receive any new updates to Brasero after you install it. Also, doing an upgrade between these commands is not recommended and could lead to serious problems with your system (and possibly even break it).

  • 1
    It should be noted that you mustn't upgrade other packages from this PPA, and once you've removed it you won't receive further updates. – Lewis Goddard Jul 19 '15 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.