1

My hardware specifications include a 256 GB HDD SSD and 8 GB of RAM. Recently, eOS has started taking around 30 seconds to load wingpanel and plank after login screen. I referred to this question earlier, but couldn't find a solution. The waiting time is unbearable. The only startup application I have is Redshift.

Recent installs include few global node packages. Looking for a solution to this.

Thanks

  • Have you tried disabling redshift? I too have noticed longer than normal start times and also use redshift. – elmato Jun 4 '16 at 3:42
  • Maybe your HDD is failing.Have you check the S.M.A.R.T info. Anyways I recommend you get an SSD (although it don't have one) – Suici Doga Jun 4 '16 at 7:03
  • @SuiciDoga My previous HDD was indeed failing and had replaced it this new SSD (wrongly mentioned as HDD in the question) a week ago. I'll still check its performance, though. Thanks. – shubhamsingh Jun 4 '16 at 12:08
  • @elmato I tried that, didn't result in any improvements. – shubhamsingh Jun 4 '16 at 12:09
  • I still can't find a solution to this problem. I would hate to do a fresh install. – shubhamsingh Jun 10 '16 at 4:52
2

A supposed fix is to run this command:

sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.disabled

I too had long boot times. I found this fix and tried it and I have not had issues with boot times since.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.