0

I've made two stupid mistakes today: I mistakenly uninstalled a lot of programs through the terminal & I tried receiving help on the ubuntu stack exchange instead of here (which I didn't know about).

1 - I ran sudo aptitude to find a specific package that I wanted to delete. I pressed "Install/Remove Pkgs" and there was a section of packages that were to be removed because they were "no longer used". So, I did a noobish move and pressed "g" to remove these seemingly unused packages.

The menu closed and the terminal processes began, I watched. I started seeing programs that were obviously being used by me. So, I hurried up and exited terminal to stop the process.

A few moments later, I saw some applications including the software center disappear. A lot of programs, packages and dependencies were wiped before I ended the process midway through the damage.

2 - I decided to go to the ubuntu stack exchange for help. I had a history log file of everything uninstalled and was hoping there was a way to get all of that back at one time. I was hoping that I could batch download/install everything that was uninstalled with that information.

For a long time, I basically got all my answers from the ubunu stack exchange. Since elementary is based on ubuntu, I thought they were pretty much the same and worked the same way.

I got an answer and due to my ignorance on desktop eviornments, one command they gave me was to reinstall the ubuntu desktop. Once I rebooted, I came to see the ubuntu login screen and that everything was literally ubuntu. I also got a hand full of errors, the application menu is semi transparent and there is most likely more issues prevalent. I now know that elementary uses the pantheon desktop, a little too late I suppose.

Though it did work in terms of reinstalling the native apps like software center at least, everything I lost earlier hasn't been recovered. But even worst, I don't have the pantheon desktop environment anymore and what I have now is messed up, probably more than what I can notice. I guess the bright side is that it does work at least. But I think I broke it.

Can anyone help me resolve this? can things be repaired? or am I just screwed?

2

Seems to me you can only do is to reinstall elementary OS. If there some files you want to backup, try it, but that's what I would do, reinstall system.

  • I don't think I can at the moment, I no longer have a flashdrive currently to reinstall/backup elementary. – Aric Jun 3 '16 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.