1

Ok, so I just downloading Elementary OS, and I love it! However, I can't seem to install Gtk+ 3.0:

ryan@DevPC-LX /media/ryan/stuff/howl/src master $ sudo apt-get install libgtk-3-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk-3-dev : Depends: libgtk-3-0 (= 3.10.8-0ubuntu1.6) but 3.14.15-0ubuntu1~14.04~ricotz1 is to be installed
                Depends: gir1.2-gtk-3.0 (= 3.10.8-0ubuntu1.6) but 3.14.15-0ubuntu1~14.04~ricotz1 is to be installed
                Depends: libglib2.0-dev (>= 2.37.5) but it is not going to be installed
                Depends: libgdk-pixbuf2.0-dev (>= 2.27.1) but it is not going to be installed
                Depends: libpango1.0-dev (>= 1.32.4) but it is not going to be installed
                Depends: libatk1.0-dev (>= 2.7.5) but it is not going to be installed
                Depends: libatk-bridge2.0-dev but it is not going to be installed
                Depends: libcairo2-dev (>= 1.13.0~20140204) but it is not going to be installed
                Depends: libwayland-dev (>= 1.2.0) but it is not going to be installed
                Depends: libxkbcommon-dev but it is not going to be installed
                Depends: libxi-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
ryan@DevPC-LX /media/ryan/stuff/howl/src master $ 

This kind of sucks, since my favorite text editor requires Gtk+ to run...

Bizarrely, installing gedit does work. Also, I already tried Aptitude:

ryan@DevPC-LX /media/ryan/stuff/howl/src master $ sudo aptitude install libgtk-3-dev
The following NEW packages will be installed:
  gcc-4.9-base:i386{a} libatk-bridge2.0-dev{a} libatk1.0-dev{ab} libc6:i386{a} 
  libcairo-script-interpreter2{a} libcairo2-dev{ab} libelfg0:i386{a} libexpat1-dev{a} libffi6:i386{a} 
  libfontconfig1-dev{a} libfreetype6-dev{a} libgcc1:i386{a} libgdk-pixbuf2.0-dev{a} 
  libglib2.0-0:i386{ab} libglib2.0-bin:i386{ab} libglib2.0-dev{ab} libgtk-3-dev{b} libharfbuzz-dev{a} 
  libharfbuzz-gobject0{a} libice-dev{a} libpango1.0-dev{ab} libpcre3:i386{a} libpcre3-dev{a} 
  libpcrecpp0{a} libpixman-1-dev{a} libpng12-dev{a} libpthread-stubs0-dev{a} libselinux1:i386{a} 
  libsm-dev{a} libwayland-dev{ab} libx11-dev{a} libx11-doc{a} libxau-dev{a} libxcb-render0-dev{a} 
  libxcb-shm0-dev{a} libxcb1-dev{a} libxcomposite-dev{a} libxcursor-dev{a} libxdamage-dev{a} 
  libxdmcp-dev{a} libxext-dev{a} libxfixes-dev{a} libxft-dev{a} libxi-dev{ab} libxinerama-dev{a} 
  libxkbcommon-dev{ab} libxrandr-dev{a} libxrender-dev{a} x11proto-composite-dev{a} x11proto-core-dev{a} 
  x11proto-damage-dev{a} x11proto-fixes-dev{a} x11proto-input-dev{a} x11proto-kb-dev{a} 
  x11proto-randr-dev{a} x11proto-render-dev{a} x11proto-xext-dev{a} x11proto-xinerama-dev{a} 
  xorg-sgml-doctools{a} xtrans-dev{a} zlib1g:i386{a} zlib1g-dev{a} 
0 packages upgraded, 62 newly installed, 0 to remove and 189 not upgraded.
Need to get 15.3 MB of archives. After unpacking 75.7 MB will be used.
The following packages have unmet dependencies:
 libpango1.0-dev : Depends: libpango-1.0-0 (= 1.36.3-1ubuntu1.1) but 1.36.8-0ubuntu1~14.04~ricotz1 is installed.
                   Depends: libpangocairo-1.0-0 (= 1.36.3-1ubuntu1.1) but 1.36.8-0ubuntu1~14.04~ricotz1 is installed.
                   Depends: libpangoft2-1.0-0 (= 1.36.3-1ubuntu1.1) but 1.36.8-0ubuntu1~14.04~ricotz1 is installed.
                   Depends: libpangoxft-1.0-0 (= 1.36.3-1ubuntu1.1) but 1.36.8-0ubuntu1~14.04~ricotz1 is installed.
                   Depends: gir1.2-pango-1.0 (= 1.36.3-1ubuntu1.1) but 1.36.8-0ubuntu1~14.04~ricotz1 is installed.
 libxkbcommon-dev : Depends: libxkbcommon0 (= 0.4.1-0ubuntu1) but 0.4.3-2~14.04~ricotz1 is installed.
 libwayland-dev : Depends: libwayland-client0 (= 1.4.0-1ubuntu1) but 1.6.0-0ubuntu1~14.04~ricotz0 is installed.
                  Depends: libwayland-server0 (= 1.4.0-1ubuntu1) but 1.6.0-0ubuntu1~14.04~ricotz0 is installed.
                  Depends: libwayland-cursor0 (= 1.4.0-1ubuntu1) but 1.6.0-0ubuntu1~14.04~ricotz0 is installed.
 libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.42.2-0ubuntu1~14.04~ricotz0) but 2.40.2-0ubuntu1 is to be installed.
 libglib2.0-0:i386 : Breaks: libglib2.0-0 (!= 2.40.2-0ubuntu1) but 2.42.2-0ubuntu1~14.04~ricotz0 is installed.
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.40.2-0ubuntu1) but 2.42.2-0ubuntu1~14.04~ricotz0 is installed.
 libxi-dev : Depends: libxi6 (= 2:1.7.1.901-1ubuntu1.1) but 2:1.7.4-1~14.04~ricotz1 is installed.
 libcairo2-dev : Depends: libcairo2 (= 1.13.0~20140204-0ubuntu1.1) but 1.14.2-1ubuntu1~trusty1 is installed.
                 Depends: libcairo-gobject2 (= 1.13.0~20140204-0ubuntu1.1) but 1.14.2-1ubuntu1~trusty1 is installed.
 libglib2.0-bin : Conflicts: libglib2.0-bin:i386 but 2.40.2-0ubuntu1 is to be installed.
 libglib2.0-bin:i386 : Conflicts: libglib2.0-bin but 2.42.2-0ubuntu1~14.04~ricotz0 is installed.
 libatk1.0-dev : Depends: libatk1.0-0 (= 2.10.0-2ubuntu2) but 2.14.0-1ubuntu1~trusty1 is installed.
                 Depends: gir1.2-atk-1.0 (= 2.10.0-2ubuntu2) but 2.14.0-1ubuntu1~trusty1 is installed.
 libgtk-3-dev : Depends: libgtk-3-0 (= 3.10.8-0ubuntu1.6) but 3.14.15-0ubuntu1~14.04~ricotz1 is installed.
                Depends: gir1.2-gtk-3.0 (= 3.10.8-0ubuntu1.6) but 3.14.15-0ubuntu1~14.04~ricotz1 is installed.
open: 59; closed: 364; defer: 44; conflict: 104                                                             .The following actions will resolve these dependencies:

      Keep the following packages at their current version:
1)      libatk-bridge2.0-dev [Not Installed]               
2)      libatk1.0-dev [Not Installed]                      
3)      libcairo2-dev [Not Installed]                      
4)      libgdk-pixbuf2.0-dev [Not Installed]               
5)      libglib2.0-0:i386 [Not Installed]                  
6)      libglib2.0-bin:i386 [Not Installed]                
7)      libglib2.0-dev [Not Installed]                     
8)      libgtk-3-dev [Not Installed]                       
9)      libpango1.0-dev [Not Installed]                    
10)     libwayland-dev [Not Installed]                     
11)     libxi-dev [Not Installed]                          
12)     libxkbcommon-dev [Not Installed]                   



Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 189 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

ryan@DevPC-LX /media/ryan/stuff/howl/src master $ 
  • i am not sure what you are trying to achive but you shouldn't install gtk 3.10 because freya has 3.14 already installed. – Djax Jun 2 '16 at 8:00
  • @Djax But it doesn't have the development files (which I needed), and any attempt to install them failed as shown above. – kirbyfan64sos Jun 2 '16 at 14:05
1

Figured it out! I just followed the directions here but instead used my text editor, going to all the APT sources files (as well as the saves!) and changing freya to trusty. One apt update later, and it installed!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.