When locking, the screen goes black and the system becomes unresponsive. I have looked carefully for available solutions and have tried them. None have worked for me. I am using Radeon R9 285/380 with the proprietary drivers. The X.ORG drivers do not support the resolution/type of my screen. Has anyone come up with a solution to this problem?

I am having the same problem as Black screen when try to lock screen and Once locked, screen stays black and cannot be unlocked

Update: I have manually installed AMD's proprietary driver and it did not fix the issue.

  • I have the same issue on a ryzen 7 computer with an NVIDIA card.
    – retiform
    Commented Jan 25, 2018 at 2:04

1 Answer 1


Have you tried maybe to switch the kernel version as it was suggested in this answer?

I've first tried (and succeeded) with a solution concerning driver update, that doesn't seem to work in your case, but maybe kernel switch could do the trick...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.