2

Microphone has a lot of interference which it doesn't have on the windows boot. This happens on a few different sound input applications, so it's not the fault of a single program either. The microphone is a 3.5mm jack type.

Clarification: This is a desktop PC.

Thanks!

4
  • Is this a laptop? Does it happen when running on battery?
    – Suici Doga
    May 30, 2016 at 14:17
  • @SuiciDoga This is a desktop, not a laptop.
    – Jimmy H
    May 30, 2016 at 14:57
  • Does the AC plug have a ground pin
    – Suici Doga
    May 31, 2016 at 1:02
  • Yes, it does have a ground pin.
    – Jimmy H
    Jun 1, 2016 at 19:04

2 Answers 2

2

If you're still searching for a solution,

I had the same problem of noise from my cheap microphone with Loki. I found the module "module-echo-cancel" which should do the job.

To test it, enter "pacmd load-module module-echo-cancel" in your terminal ; then you should have a new input device with "echo cancelled" in the name.

If you're satisfied, you have to add "load-module module-echo-cancel" to your pulseaudio config file (for me, it's /etc/pulse/default.pa)

1

You probably have that interference because elementary OS doesn't have noise reduction for the microphone.
Some apps include noise reduction so you can use it on those. You also can reduce a bit the noise by decreasing the volume and/or the gain.
To do so, open a terminal and type alsamixer, then press F4 and change the volume and gain levels.
Beware that if you change the microphone volume from any other place it will affect those settings as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.