1

I downloaded Foxit Reader (a PDF reader) and Popcorn time. To install them, running an executable file is needed, but even if I give them the permission to be executed by everyone (Not just the root user), After double clicking or choosing 'Run' option nothing happens. I tried

sudo chmod +x filename

and then running it, even that didn't work. I really don't know why.

If I try to run them through the terminal (Using 'sh' command or by just typing the name of the executable file) I get an error saying the no such directory exists.

I downloaded new file manager (PCManFM), When i double clicked the executable file, a pop up appered asking me to 'Execute', 'Execute in Terminal' or 'Cancel', of course non of the options worked. I'm running Elementary OS 0.3.2 64bit

  • 1
    try droping the excutable file in the terminal and press enter a look if it drops any error, if it does, post the output here – Alexandr Jun 29 '16 at 16:09
  • 1
    Did you by chance download the 32 bit binaries? The 'no such directory exists' error on executable files tends to happen because of exactly that. – Samuel Jun 29 '16 at 19:36
1

Have you tried installation as on https://www.foxitsoftware.com/downloads/thanks.php?product=Foxit-Reader&platform=Linux-64-bit&version=1.1.0.0225&package_type=run&language=English advised?

filename.run executable will be start with ./filename.run Also you can start it from filemanager with right click extract. I have tested Foxit Reader without problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.