Wrong Shadow

Almost every window from the core elementary os applications displays a wrong shadow (you can see exactly how wrong in the picture above). If I boot using software rendering (boot on secure mode and resume boot normally) the shadow works okay, but as it is software, everything is slowed to an unusable state.

Affected apps

Applications that are affected by this include (but are not limited to):

  • terminal
  • geary
  • files
  • midori
  • camera
  • music
  • maya

Applications that are not affected by this include:

  • firefox
  • gvim
  • atom
  • audacity
  • google chrome


E.g: it appears to happen only with GTK3 applications and not with GTK2 ones.

I tried:

I already tried doing:

sudo apt-get update && sudo apt-get dist-upgrade

and then rebooting, but so far nothing changed.

I tried the solution mentioned here, but the result was:

sudo apt install xserver-xorg-video-intel=2:2.99.910-0ubuntu1.3+elementary2+r3~ubuntu0.3.1
E: Version '2:2.99.910-0ubuntu1.3+elementary2+r3~ubuntu0.3.1' for 'xserver-xorg-video-intel' was not found
  • 2
    Try sudo apt install xserver-xorg-video-intel, there shouldn't be a need for a specific version.
    – Lewis Goddard
    Jul 18, 2015 at 6:39
  • Thanks @LewisGoddard, after a bit of pain it worked. (see my answer) Jul 18, 2015 at 8:32

1 Answer 1


I tried the solution proposed on the comments:

sudo apt install xserver-xorg-video-intel

But it didn't work because I had xserver-xorg-video-intel-lts-utopic installed, which causes a conflict.

To solve this, I used aptitude to install it (xserver-xorg-video-intel) and remove the conflicting packages:

sudo aptitude install xserver-xorg-video-intel

But then aptitude removed some core packages, mainly elementary-desktop, because they depended upon the -lts-utopic version of the xserver-xorg-video-intel package. To solve this issue, I added the stable elementary ppa with:

sudo add-apt-repository ppa:elementary-os/stable

and reinstalled the elementary-desktop package:

sudo apt-get update && sudo apt-get install elementary-desktop

after a reboot the shadows are working again!

  • 3
    Uhm, it's great it's working again, but did you remove the stable PPA before all these issues happened?
    – embik
    Jul 18, 2015 at 9:03
  • In fact, I do not know for sure, but given that apt couldn't find the elementary-desktop package before adding the stable PPA, I bet so. Jul 18, 2015 at 16:42
  • 2
    Well, don't get me wrong, but if there are crucial repositories missing it's small wonder things do not work as intended ... Usually this doesn't simply "happen".
    – embik
    Jul 18, 2015 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.