3

I have 2 files on my NTFS partition. One of them is 666 bytes and the other is 0 bytes. When trying to delete them it says that it does not exist

I have tried the rm command from the terminal and it does not work

  • How are the files called? – Andrea Lazzarotto May 23 '16 at 10:07
  • @AndreaLazzarotto Do you mean the file name – Suici Doga May 23 '16 at 10:32
  • Yes, precisely. :) – Andrea Lazzarotto May 23 '16 at 10:37
  • @AndreaLazzarotto It is IE11 - Win8.1.ova. I tried deleting with sudo rm "./IE11 - Win8.1.ova" but it doesn't work – Suici Doga May 23 '16 at 10:39
  • I am not sure about that ./ inside the quotes. You tried also without those two characters, right? – Andrea Lazzarotto May 23 '16 at 13:11
1

What if you try to delete them from Files? What happens?

I had the same problem in the past, it was related to encoding of file names.

There is a program ntfsfix that can fix some ntfs problems:

sudo ntfsfix /dev/sd(your partition here)

According to the man pages:

ntfsfix is a utility that fixes some common NTFS problems. ntfsfix is NOT a Linux version of chkdsk. It only repairs some fundamental NTFS inconsistencies, resets the NTFS journal file and schedules an NTFS consistency check for the first boot into Windows.

You may run ntfsfix on an NTFS volume if you think it was damaged by Windows or some other way and it cannot be mounted.


Also there is this interesting link, could be helpful:

https://www.cyberciti.biz/tips/delete-remove-files-with-inode-number.html

Another interesting link:

https://www.linuxquestions.org/questions/linux-newbie-8/can-two-files-have-the-same-inode-number-423094/

-2

Have you tried [Be careful with sudo and rm... great power great responsibility]:

sudo su
rm "[full path of the file]"
  • It says no such file or directory – Suici Doga May 22 '16 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.