After a regular software update, the program previously called "Calculator" is now called "Unnamed".

In the applications menu, the icon is still correct, but the program is now called unnamed.

In the launch panel, the icon is now the default gear icon, rather than the calculator icon.

Clicking on any of them still opens the calculator program though.

Has anyone else seem this problem or know of a way to correct it?

I am using elementary OS 0.3.2 Freya (64-bit)

  • I added a answer. Mark it as answer if it works
    – Suici Doga
    May 20 '16 at 14:39
  • You really, really should not be running the daily PPA. It is unstable and you're going to encounter problems like this while running it. May 20 '16 at 22:04

Run the following command to open the calculator entry in Scratch

sudo -i scratch-text-editor /usr/share/applications/pantheon-calculator.desktop

Change the text after line that starts with Name= (it should currently be unnamed or something , if the line isn't there add it) to Calculator.

Or replace the contents of the file with (from my laptop)

[Desktop Entry]
Comment=Calculate in an elementary way.
Exec=pantheon-calculator %U


[AboutDialog Shortcut Group]
Name=About Calculator
Exec=pantheon-calculator --about
  • 2
    Just looked at my system (had the same problem). For some reason the entries "Name=Calculator", "Comment=..." and "Name=About Calculator" were instead "_Name=Calculator", "_Comment=..." and "_Name=...". Removing the underscores fixed the problem. May 21 '16 at 2:10
  • @TimothyGray Can you mark this as answer since it worked
    – Suici Doga
    May 21 '16 at 2:22
  • I'm not the original poster, so I don't think so May 21 '16 at 2:24
  • This answer and the comment from Timothy Gray fixed it for me. Thanks.
    – Michael
    May 23 '16 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.