3

Got elementary OS installed at the local Neighbors House after shifting the original GPU, RAM and finally a defective motherboard. Yeah ':-p Will hopefully serve as a demo box for people around.

To achieve that I need to customize the Guest session, particularly the language, but am stuck half-way. Your ideas are welcome!

EDIT: screenshot of the partial (very incomplete) result with the settings below:

Eos Guest account partial localization

/etc/default/locale

LANG=fr_FR.UTF-8
LANGUAGE=fr_FR.UTF-8:en_US
LC_MESSAGES=POSIX
LC_PAPER=A4LC_TIME=fr_FR.UTF-8

$ locale

LANG=fr_FR.UTF-8
LANGUAGE=fr_FR
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY=fr_FR.UTF-8
LC_MESSAGES=POSIX
LC_PAPER=fr_FR.UTF-8
LC_NAME=fr_FR.UTF-8
LC_ADDRESS=fr_FR.UTF-8
LC_TELEPHONE=fr_FR.UTF-8
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION=fr_FR.UTF-8
LC_ALL=

$ dpkg --list|grep language

ii  language-pack-en                           1:14.04+20150219   all      translation updates for language English
ii  language-pack-en-base                      1:14.04+20150219   all      translations for language English
ii  language-pack-fr                           1:14.04+20140707   all      translation updates for language French
ii  language-pack-fr-base                      1:14.04+20140707   all      translations for language French
ii  language-pack-gnome-en                     1:14.04+20150219   all      GNOME translation updates for language English
ii  language-pack-gnome-en-base                1:14.04+20150219   all      GNOME translations for language English
ii  language-pack-gnome-fr                     1:14.04+20140707   all      GNOME translation updates for language French
ii  language-pack-gnome-fr-base                1:14.04+20140707   all      GNOME translations for language French
1

Go to System Settings > Language and Region. Click unblock and select your language and click Set Language.

Reboot

  • Thank you @Suici Doga, but clicking unblock while in the Guest session does not work: stay locked. Maybe I'm missing something? Also if that worked, do you know whether it would keep the locale for the next guest session? – tuk0z Jun 2 '16 at 11:12
0

The reponse to the question how to customize guest session should help you to customize your guest session.

You might want to create a new test user, customize System Settings > Language and Region and Set Language as suggested by Suici Doga and copy these files to /etc/guest-session/skel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.