2

I installed pulseaudio-equlizer to increase the quality of sound in my laptop. But after installing it, when playing videos in vlc player sound volume got increased and got decreased from time to time automatically, just like manually doing it. I thought that may be due to the newly installed pulseaudio so I uninstall it through apt-get remove --purge pulseaudio found on here after that when I restart my lap, sound icon is not shown in the top right corner and sound device is not shown in the sounds in the settings. Please help me to fix this error, as I can't reinstall the OS again. Thanks in advance.

  • Run sudo apt-get install pulseaudio to install it again – Suici Doga May 16 '16 at 14:42
  • @Suici Doga it says pulseaudio is already the newest version. why is that – Kasun Siyambalapitiya May 16 '16 at 14:47
  • Try removing and installing it – Suici Doga May 17 '16 at 1:11
2

I found the solution for it. First I removed any traces of pulseaudio and pulseaudio-equalizer by using the below command

sudo apt purge pulseaudio pulseaudio-equalizer

then

removed following directories using the following command

rm -rf /etc/pulse /usr/share/pulseaudio usr/share/pulseaudio-equalizer

then reboot the system. Next reinstalled pulseaudio using the following code

sudo apt install pulseaudio

(internet connection is needed) finally reinstalled elementary-dekstop using the following command

sudo apt install elementary-desktop

after reboot, move aside the ~/.config/pulse folder (on a Elementary OS 'Loki' system, audio device was still missing until I did this step; immediately after I deleted the pulse folder, the default sound device reappeared as desired)

cd ~/.config/pulse && tar -zcf pulse.tar.gz pulse && rm -rf pulse

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.