As explained here How can I fix Networking, Wi-Fi and Ethernet, not being available after update? there is a regression bug that will cause some systems to lose network entirely.

Lewis' excellent answer solves the issue, but after applying it I am immediately requested by the system to upgrade the downgraded libraries:

enter image description here

As far as I can tell, I have the Poposed repository[*] deselected:

enter image description here

Lewis says to "so comment out the lines in /etc/apt/sources.list", but I'm not sure which lines he is referring to.

[*]: I actually have all of the repositories in the Updates tab deselected. Is this how they should show?

  • I have that update available on my PC.Should I update
    – Suici Doga
    Commented May 15, 2016 at 1:41
  • 1
    I ran it.Internet is working correctly
    – Suici Doga
    Commented May 15, 2016 at 2:07

1 Answer 1


Well, quoting this awesome answer on askubuntu, you have to mark the packages on hold:

sudo apt-mark hold libnl-3-200 libnl-genl-3-200 libnl-route-3-200

That worked for me really great


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.