1

A couple of weeks ago the last.fm plug-in stopped working for me, I reported the bug here here, however I really miss scrobbing my songs! Could anyone please help me fix this?, I have no idea where to start.

** (noise:3152): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-LILgC2mGlt: Connection refused
[_LOG_LEVEL_INFO 19:39:45.687148] Application.vala:155: Music version: 0.3.1
[_LOG_LEVEL_INFO 19:39:45.687209] Application.vala:157: Kernel version: 3.16.0-43-generic
[_LOG_LEVEL_FATAL 19:39:45.983791] [GLib-GObject] Read-only property 'read-only-view' on class 'GeeReadOnlyBidirSortedSet' has type 'GeeSortedSet' which is not equal to or more restrictive than the type 'GeeBidirSortedSet' of the property on the interface 'GeeBidirSortedSet'
[_LOG_LEVEL_FATAL 19:39:45.983831] Music will not function properly.
[_LOG_LEVEL_WARN 19:39:46.109681] [libpeas] lastfm: /usr/lib/x86_64-linux-gnu/noise/plugins/LastFM/liblastfm.so: undefined symbol: gtk_label_set_xalign
[_LOG_LEVEL_WARN 19:39:46.109825] [libpeas] Error loading plugin 'lastfm'
[_LOG_LEVEL_INFO 19:39:46.110292] AudioPlayer.vala:28: Activating AudioPlayer Device plugin
[_LOG_LEVEL_INFO 19:39:46.110519] Plugin.vala:43: Activating MPRIS plugin
[_LOG_LEVEL_INFO 19:39:46.110652] CDRom.vala:28: Activating CD-Rom Device plugin
[_LOG_LEVEL_INFO 19:39:46.110782] iPod.vala:28: Activating iPod Device plugin~

closed as off-topic by Lewis Goddard Jul 24 '15 at 5:59

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Generally bugs are offtopic, but if a workaround can be found or if the bug is unconfirmed I think it should stay open. – Lewis Goddard Jul 17 '15 at 17:45
  • From the output here, I'm seeing an undefined symbol lookup error. This means that the version of Noise you're using has been built with Vala 0.28 and that particular piece of code hasn't been updated. Since the last release of Noise was in April, I'm guessing you're using the daily PPA. This is a bug and the only workaround is to fix it in code, so I think this should indeed be closed. – Daniel Foré Jul 17 '15 at 18:45
  • possible duplicate of How can I report an issue with elementary OS to the developers? – Daniel Foré Jul 17 '15 at 18:45
  • @DanielForé, the thing is that I am not using daily packaging archive; my only additional PPAs are for Vocal, LibreOffice, Gimp and Transmission. Also, as you say, I don't recall any Noise related updates in the last weeks. – user1203684 Jul 18 '15 at 10:02
  • 1
    @user1203684 as Lewis commented above, bug reports are generally considered offtopic for StackExchange, especially since there's no workaround for this error. It has to be fixed in code. – Daniel Foré Jul 18 '15 at 16:36

Browse other questions tagged or ask your own question.