0

Just downloaded the most recent update today. After restart, I have no networking capability whatsoever. No wifi, no wired, nothing. Opening networking through settings gives me an error message to the effect of "your network settings aren't compatible with this build " (can't remember the exact wording. Without any internet, I can't download any updates or try to undo the last one. If it matters, I'm using a Lenovo yoga laptop. Help!!!

  • I am having the exact same issue. Updated this morning. Shut down after the update, went to turn it on and the network is lost. When I go to the Settings page for Network I get an error message saying the following: The system network services are not compatible with this version. – user5039 May 14 '16 at 4:24
  • Same issue! Internet is not working! – user5043 May 14 '16 at 6:16
  • 1
    Got the same issue. See askubuntu.com/questions/727127/… – 0skar May 14 '16 at 8:48
  • Sorry for mistakenly commenting as an answer as this is my first time on StackExchange. Pavel Janicek's answer solved the issue. All I needed to do was to download libnl libnl-genl libnl-route from another computer that has access to the internet and sudo dpkg -i libnl-*.deb the *.deb files. Hope this helps. – user5048 May 14 '16 at 10:38
2

Because this is most visited question regarding this topic on Elementary OS, I have solution for you

There is solution described on AskUbuntu

To cite the answer:

This is caused by a regression introduced with a fix for libnl3 bug #1511735.
Resulting network-manager crash has been reported in network-manager bug #1539513 or network-manager bug #1539634

and you need to downgrade these packages

The first link helped me, hope it will help you too

| improve this answer | |
0

I had the same problem and downgrading the libnl packages worked too.

I rebooted using a live USB , downloaded libnl-3-200-3.2.21-1_amd64.deb, libnl-genl-3-200_3.2.21-1_amd64.deb and libnl-route-3-200_3.2.21-1_amd64.deb from http://archive.ubuntu.com/ubuntu/pool/main/libn/libnl3/ , installed it using dpkg -i and rebooted.

Internet should be working now.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.