After one of the latest updates and a reboot my network manager is not able to start anymore, dmesg tells me that it gets killed every time it wants to start. How can I fix that? No internet is a pretty huge problem for me...


I had the same problem and downgrading the libnl packages worked too.

I rebooted using a live USB , downloaded libnl-3-200-3.2.21-1_amd64.deb, libnl-genl-3-200_3.2.21-1_amd64.deb and libnl-route-3-200_3.2.21-1_amd64.deb from http://archive.ubuntu.com/ubuntu/pool/main/libn/libnl3/ , installed it using dpkg -i and rebooted.

Internet should be working now.


Try running the following to downgrade the network manager

sudo apt-get install libnl-3-200=3.2.21-1 libnl-route-3-200=3.2.21-1 libnl-genl-3-200=3.2.21-1
  • You should also add the offline version, this version will not work for me.
    – arc_lupus
    May 13 '16 at 12:08
  • Which version worked for you
    – Suici Doga
    May 13 '16 at 12:17
  • The offline-version, after I had no internet any more
    – arc_lupus
    May 14 '16 at 5:04
  • @arc_lupus Is it the one from Howtogeek or AskUbuntu
    – Suici Doga
    May 14 '16 at 5:31
  • @arc_lupus I have added the offline version
    – Suici Doga
    May 14 '16 at 5:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.