I'm using freya 3.2 and after installing TLP Advanced Power Management the audio jack isn't working anymore. The strange thing is that the notebook's loudspekakers are working regularly (when headphones are not plugged in). Also, the headphones are working in other devices.

In Detail, what I did between sound-working and sound-not-working was to install tlp and tlp-rdw as described in this post. I also installed gksudo, which didn't work properly, thus I purged it again.

I have a Dell XPS 13 (2015). Does anybody have an idea where to start investigating the cause, or maybe even a solution?

EDIT: Headphones are recognized and selected, but sound doesn't work.

settings sound

2 Answers 2


Actually I found this question which is very similar and has a solution in a comment..

The solution is to activate the correct sound card in the alsamixer equalizer. This can be done by typing alsamixer in a terminal and using F6 to choose a sound card.

If speakers, headphones, mics, etc. are muted, this can also be changed with the alsamixer equalizer.


Can you check under System Settings > Sound > Output tab, the output source, while you have plugged your headphones in ? I assume that wrong output is selected.

  • As soon as I plug in the headphones, they are selected. When I select internal audio as output, the sound works again. Do you have other ideas or does selected in this context mean something else?
    – jmjr
    Commented May 9, 2016 at 12:53
  • I 'm sorry, I don't have access to eOS right now. Can you add a screenshot of sound settings > output ?
    – ounos
    Commented May 9, 2016 at 13:00
  • I edited the question. Now there's a screenshot.
    – jmjr
    Commented May 9, 2016 at 13:22
  • There are so many reports regarding dell xps sound card problems. Do you dual boot eos/windows ?
    – ounos
    Commented May 9, 2016 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.