2

I have installed Elementary OS recently. At some point my touchpad stopped to work. Not completely, but I cannot move it, all I can do is click.

I have tried to enable it at settings. Turning on/off on laptop shortcuts. Nothing really worked.

It worked before, but somehow stopped. Any ideas guys?

Laptop Lenovo Y510P, ETPS/2 Elantech Touchpad.

Best, Jacob

1

I have fixed it somehow while struggling with Bumblebee and Primus.

I believe sudo apt-get install xorg-x11-drv-mouse might be the answer.

1

If you don't already have these drivers, I would recommend installing them:

sudo add-apt-repository ppa:hanipouspilot/focaltech-dkms
sudo apt update
sudo apt install focaltech-dkms
sudo modprobe -r psmouse 
sudo

modprobe psmouse

If this doesn't help try the following command as root:

echo 1 > /sys/devices/platform/i8042/serio4/reg_07

These worked for me when I had that laptop, but that was about 6 months ago, so not sure if that's still the problem. I just know that Elantech touch-pads don;t seem to like debian based distros.

if neither of these works, you can try install the gcc drivers (I haven't personally tried these though):

sudo apt install switchboard-plug-gcc-mouse

Some helpful links, for reference:

  • I believe I have these drivers installed, but just for sure followed commands. And the echo didn't work at all. bash: /sys/devices/platform/i8042/serio4/reg_07: No such file or directory I have also GCC drivers installed. Maybe that's the reason why? EDIT: Uninstalled GCC drivers and didn't help. – Murkee May 3 '16 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.