2

After removing Viber version 5 from software center, and with

sudo dpkg --purge viber
sudo apt-get remove viber

I downloaded the version 6 viber .deb file from Viber's website, opened it and installed it with software center. When trying to launch Viber I get an error. And by running

/opt/viber/QtWebEngineProcess

in terminal, i get

[0425/170521:FATAL:browser_main_loop.cc(161)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on. Aborted (core dumped)

update: By running:

opt/viber/Viber

in terminal i get:

This application failed to start because it could not find or load the Qt platform plugin "xcb".

Reinstalling the application may fix this problem. Aborted (core dumped)

3
sudo apt-get install libqt5gui5

Run this in terminal and then reinstall viber.deb This resolves the issue.

1

I never use software center for installation, so I do not know how it handles .deb files. But maybe gdebi can help you:

$ sudo apt-get install gdebi
$ sudo gdebi viber6-XXX.deb

This will install all related dependencies.

0

For those who prefer to solve issues from the command line, simply run:

sudo apt-get install -f

...whenever a deb you've installed didn't have its dependencies resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.