I've tried installing steam using the .deb file from their webpage and ran into the same problem found here. I got rid of the problem as described, but when trying to launch steam nothing happens, and I can't even launch it from terminal.

I then tried to install it using the command line apt-get (I even tried using aptitude), and although these don't give me any errors, nothing happens when I try run steam.

I purged steam between each attempt, and even deleted the .steam folder which doesn't seem to delete when steam is purged.

I have the latest Nvidia drivers installed.

Any help would be greatly appreciated.


I now get the following when running steam from command line.

:~$ steam
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2016-04-23 12:54:29] Startup - updater built Nov 25 2013 18:07:05
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
  • Could be your GPU drivers. What is your GPU
    – Suici Doga
    Commented Apr 23, 2016 at 11:32
  • @SuiciDoga I have a Nvidia gtx 970, with the latest drivers. I read somewhere that I may need to use the latest stable version, but not sure how to uninstall custom installed drivers. Commented Apr 24, 2016 at 13:09
  • Install steam from appcentre directly. There's no need for a deb file.
    – Maccer
    Commented Mar 10, 2018 at 22:23

2 Answers 2


It looks like you're missing xfonts required to launch steam. You can install them with sudo apt-get install xfonts-75dpi. Then log out, log back in, and launch steam again.

If that fails try sudo apt-get install xfonts-100dpi or sudo apt-get install xfonts-75dpi-scalable.


You could try installing steam from app center built into elementary! Just search steam and hit the free button.

  • This thread is two years old. But thanks. At the time app center didn't exist. Commented Mar 12, 2018 at 6:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.