0

I'm having some kind of an issue where, eos freya does not detect my 1tb hard drive. I just installed eos and all is well, until i tried to insert my hard disk. I tried inserting my 8GB usb and it was detected. Anyone encountered this issue?

  • first you need to check the type of your harddisk using Gparted – user4825 Apr 21 '16 at 8:51
  • It should appear under the "Devices" header as a disk, although it will not mount automatically. Try running sudo fdisk -l and see what it outputs. – Lewis Goddard Apr 21 '16 at 17:57
2

If your external hard drive is brand new, then it has never been formatted. I am going to assume this is the case as I had this same result with a new external drive.

Although, if your drive is encrypted, then Elementary cannot open the drive and see the files. Your drive may be encrypted, but you would know if you did that.

You will need to install and run gparted to add a partition to your external drive. Run the commands:

sudo apt-get install gparted
sudo gparted

Once gparted is open look for your device on the top right. BE SURE YOU HAVE SELECTED THE RIGHT DEVICE OR ALL YOUR DATA WILL BE LOST! Then you can add a new partition to your drive. After you have a new partition on your drive, unplug it, then plug it into a different usb port. It should show up in the file manager now.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.