1

I am already tried looking for my problem in this forum without no lucky, it seems to me just an aesthetics thing but it is a little annoying. I have a gamer keyboard (MadCatz Strike 5), and when it's plugged and I turn the computer on, the system, instead of shows the elementary OS logo, it shows a black screen with 3 "errors" and I couldn't find anything about them. i attached a picture where you will be able too see the screenshot. Do you have any suggestions?

It's important to point, that this black screen only appears when the keyboard is plugged.

enter image description here

  • Try kernel 4.4. – Suici Doga Apr 19 '16 at 5:54
  • I installed kernel 4.5 following your suggestion and now i can see the Elementary Logo!!!! , i had to uninstall propietary nvidia drivers and install xorg noveau drivers before to make the kernel update, the problem is, now i can't install propietary drivers (i mean i can do it from additional drivers), because Graphical environment doens't work, and with noveau i feel the "animations" slower than before. Any suggestion? – Oliver Apr 20 '16 at 2:38
  • For me it wasn't slow.I have AMD but you have NVIDIA.I also couldn't install the AMD drivers – Suici Doga Apr 20 '16 at 4:34
  • I will post as an answer since the NVIDIA driver is something else which you could ask as another question – Suici Doga Apr 20 '16 at 6:06
  • Is your system heating up – Suici Doga Apr 20 '16 at 6:13
0

Try installing Linux kernel 4.5.

To do it run the following in the terminal to download the kernel

For 32-bit

cd /tmp
wget \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-headers-4.5.0-040500_4.5.0-040500.201603140130_all.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-headers-4.5.0-040500-generic_4.5.0-040500.201603140130_i386.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-image-4.5.0-040500-generic_4.5.0-040500.201603140130_i386.deb

For 64-bit

cd /tmp
wget \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-headers-4.5.0-040500_4.5.0-040500.201603140130_all.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-headers-4.5.0-040500-generic_4.5.0-040500.201603140130_amd64.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-image-4.5.0-040500-generic_4.5.0-040500.201603140130_amd64.deb

And then install the kernel (for both 64 and 32)

sudo dpkg -i linux-headers-4.5*.deb linux-image-4.5*.deb

Reboot

|improve this answer|||||
0

This works for me, pointing that i have Nvidia 960

Step 1 Download and install Kernel 4.0 Packages from

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/

In my case for x64

linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb
linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb
linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb

and install the new kernel

sudo dpkg -i linux-headers-4.*.deb linux-image-4.*.deb

And Nvidia last drivers from it official website (you will download as a script i think, so you will have to give it execute permissions with chmod +x)

http://www.nvidia.es/Download/index.aspx?lang=es

Step 2 Uninstall nvidia's and nouveau's drivers

For get no errors, i did it in recovery mode, in a console as root, you will need reading and writing permissions

mount -o remount,rw /

For some reason when i did that the first time, comand return me an "error", the second time i wrote the sentence, it worked.

once i got reading/writting permissions i proceeded to uninstall all drivers

apt-get remove --purge nvidia*
apt-get remove --purge xserver-xorg-video-nouveau*

and install the executable file that you downloaded from nvidia offical website, i will put my file name.

cd /home/oliver/Download
 ./NVIDIA-Linux-x86_64-361.42.run

This way now i can access to TTY console, see the elementary logo and Graphical environtment in full resolution.

But ... the elementary logo looks pixelated, TTY in 600x400 so ...

Step 3

In my case for some reason i couldn't install rEFInd as user Suici Doga recommend. So i did manually editing /etc/defaul/grub

sudo nano /etc/default/grub

and adding

GRUB_GFXMODE=1920x1080  # not "auto"
GRUB_GFXPAYLOAD_LINUX=keep

then updating grub

sudo update-grub

I read that is important to know what resolutions your monitor and grub support before to editing the grub file, you can do it with hwinfo ... i couldn't install it, i think it was because i spent many hours trying to find de complete solution (you know trial and error).

Thanks to user Suici Doga for his help!

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.