I just get a new laptop and I can't manage to install Elementary Freya on it. Live CD doesn't launch, same for the install process, all I get is some Kernel lines and the process stopped.Ubuntu 16.04 beta get until the live session (only with the option 'AHCI disable' otherwise, same things, kernel lines and process stopped..)

I have a SSD Samsung M.2 NVMe, and an i7 Skylake + Geforce GTX 950m. Windows 7 is already installed, I want to do a dual boot.

I've check and some people can get through the install procedure by disable the discrete GPU from the BIOS, but I don't have the option on mine (ridiculous...).

I was thinking maybe recompiling the ISO of Freya with the last linux 4.5 Kernel (because the live cd of Ubuntu 16.04 is running), but I have absolutely no idea how I can do that..

Any ideas ?

MAny thanks !

  • What PC is this. Ubuntu 16.04 uses kernel 4.4
    – Suici Doga
    Apr 18, 2016 at 1:18
  • Can you add a photo
    – Suici Doga
    Apr 18, 2016 at 3:27
  • it's this one : pcspecialist.co.uk/notebooks/SkyFireV-14
    – neodyme
    Apr 18, 2016 at 9:34
  • It's working on live cd with the 4.4 kernel of Ubuntu 16.04, but as far as I reckon, there are been some improvement with the nvidia optimus technology with the last 4.5 kernel. That's why I was thinking recompiling Freya with the 4.5 kernel already on the ISO..
    – neodyme
    Apr 18, 2016 at 9:36
  • Have you tried to boot with "nouveau.modeset=0" grub option?
    – bitseater
    Apr 18, 2016 at 15:04

3 Answers 3


Thanks !

I manage to install Freya, install the latest Nvidia Drivers for the kernel 3.19 BUT impossible to update to kernel 4.2, 4.4 and 4.5, just got black screen.. I tried to add nouveau.modeset=0 or nvidia.modeset=0 , nomodeset even modprobe.blacklist=nouveau

On Ubuntu 16.04 beta with the kernel and acpi=off, I can go to the live CD, no boot from Freya with 4.4.

The wifi is not working either, the card is not recognized, I guess it's fixed with the 4.4 kernel.

I'm quite running out of option here

EDIT - same result with Nvidia Drivers 364 removed and nouveau.modeset=0


when i was trying to solve a problem i got a problem similar than yours, i had problems installing 4.5 kernel, if you can't do it from freya, download kernel and nvidia linux driver from windows and put them in a pendrive

Step 1 Download and install Kernel 4.0 Packages from


In my case for x64

linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb

and install the new kernel

sudo dpkg -i linux-headers-4..deb linux-image-4..deb

And Nvidia last drivers from it official website (you will download as a script i think, so you will have to give it execute permissions with chmod +x)


If elementary doesn't start, enter in the recovery mode and then in root console, you will need reading and writing permissions

mount -o remount,rw /

then install first the kernel 4.0 and reboot and then enter in recovery mode for the kernel 4.0 --> consola as root and uninstall all drivers

apt-get remove --purge nvidia* apt-get remove --purge xserver-xorg-video-nouveau*

and install the executable file that you downloaded from nvidia offical website

./NVIDIA-Linux-x86_64-361.42.run (in my case)

This way now i can access to TTY console, see the elementary logo and Graphical environtment in full resolution.

  • thanks for the reply :) After 3 days fighting with Freya, I gave up an install Xubuntu 16.04, put the 4.5 kernel, blacklist the nouveau drivers, install bbswitch-dkms, add bbswitch to /etc/modules-load.d and turn off power to the nVidia GPU using: sudo tee /proc/acpi/bbswitch <<<OFF Just using the nvidia card on windows for gaming
    – neodyme
    Apr 23, 2016 at 9:56
  • and I tweak Xubuntu with Plank and install pantheon-files, waiting for Loki to be released..!
    – neodyme
    Apr 23, 2016 at 10:02

I've got an MSI laptop same specs. and I'm having no end of issues installing Ubuntu. Same problems with the live CD. I did manage to get 16.04 installed but on reboot all I got was a desktop background and that's it, Unity didn't finish loading.

Other than waiting for firmware updates and Ubuntu 16.10, I don't know what else to do. I will use windows 10 as a last resort but I really don't want to use windows so any help would be really appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.