2

So by default Scratch comes with the option that changes your tabs from being tabs to just spaces. Now, this works fine whilst within Scratch, and i'm not arguing the fact that this silly option is on by default, I am of the opinion it shouldn't be. This might be a bug in Scratch, but before I go bughunting, I want to see if anyone else had this problem and might have a fix.

So when i Disable the "Change tabs to spaces" option, it still gives white spaces instead of full tabs. So when i open files with Microsoft word, or even libre office for that matter, the tab index is completely wrong. All my carefully planned tabbin' for nought.

1

So the problem was with the "Detect Indent" addon. It kept the format of a text file i had made earlier across the entire program.

To solve:

  1. close all open tabs
  2. Disable the "Detect Indent" addon
  3. restart scratch
  4. Everything is back to normal, and you can enable the "Detect Indent" addon again. It now works fine across documents.

Not the answer you're looking for? Browse other questions tagged or ask your own question.