6

I have been struggling with setting up an IPSEC/L2TP based VPN for a couple of days, and I'm leaning towards that it's broken upstream. After running sudo apt-get install l2tp-ipsec-vpn, the ipsec verify command shows the following output:

Checking your system to see if IPsec got installed and started correctly: 
Version check and ipsec on-path                                 [OK]
Linux Openswan U2.6.38/K(no kernel code presently loaded)
Checking for IPsec support in kernel                            [FAILED]
SAref kernel support                                        [N/A]
Checking that pluto is running                                  [FAILED]
whack: Pluto is not running (no "/var/run/pluto/pluto.ctl")
Checking for 'ip' command                                       [OK]
Checking /bin/sh is not /bin/dash                               [WARNING]
Checking for 'iptables' command                                 [OK]
Opportunistic Encryption Support                                [DISABLED]

After running "sudo service ipsec start", this is what "sudo service ipsec status" outputs:

IPsec stopped but... has /var/run/pluto/ipsec.info file!

My guess so far is that ipsec/openswan somehow expects to find pluto in another location and thus is unable to start it. I can start pluto manually with /usr/lib/ipsec/pluto --stderrlog, but for some reason ipsec can't seem to start it.

Has anyone succeeded in setting up an ipsec/l2tp vpn in Freya, and in that case, what did you do to make it work?

  • I can confirm that OpenVPN does work. You can tryit if it suits your needs – Mrpopo666 Apr 13 '16 at 9:47
  • Yes, OpenVPN works fine. Sadly enough, the site in question only offers IPSEC/L2TP so I need to get it working :( – rambolino Apr 13 '16 at 18:24
2

This worked for me:

First install the following dependencies:

sudo apt install git intltool libtool network-manager-dev libnm-util-dev libnm-glib-dev libnm-glib-vpn-dev libnm-gtk-dev libnm-dev libnma-dev ppp-dev libdbus-glib-1-dev libsecret-1-dev libgtk-3-dev libglib2.0-dev xl2tpd strongswan libnss3-dev

Issue the following on the command-line (note: the backslash character \ is the shell line continuation character which can safely be copy and pasted):

git clone https://github.com/nm-l2tp/network-manager-l2tp.git
cd network-manager-l2tp
autoreconf -fi
intltoolize

./configure \
  --disable-static --prefix=/usr \
  --sysconfdir=/etc --libdir=/usr/lib/x86_64-linux-gnu \
  --libexecdir=/usr/lib/NetworkManager \
  --localstatedir=/var \
  --with-pppd-plugin-dir=/usr/lib/pppd/2.4.7

make
sudo make install

source: here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.