3

Laptop WiFi gets disconnected after about 5 to 10 minutes. WiFi connection works after restarting but again will get disconnected after some time.

WiFi hardware used is: Realtek rtl8723be

I have gone through various posts to fix the issue. But I couldn't find any proper solution. Please do help me find the proper solution to the problem.

2

I have that same WiFi card on an HP Pavilion X360.

On my laptop wifi was completely broken. I had to blacklist the default acer-wmi module and install a patched version from: https://github.com/lwfinger/rtlwifi_new

I also had to add this line to my /etc/modprobe.d/rtl8723be.conf

options rtl8723be ips=N fwlps=N swlps=N swenc=Y disable_watchdog=Y ant_sel=2 msi=1

Since your wireless was technically working, unlike mine, but just dropping connections, I wouldn't recommend cloning that github repository. That's just what got mine working, but adding those options to your rtl8723be.conf file might help. Just be sure to backup the original version of that file just in case these changes makes things worse.

Some more information on your laptop would be helpful.

  • Have you ever encountered with a disconnection after installed this repo? – efkan Dec 26 '16 at 4:42
0

That's a known issue with Realtek wireless card. You must deactivate power management.

Try from terminal :

echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.