1

Problem: Clicking the app-icons does not launch anything. I've checked out (and tried some of) these solutions:
software-center-does-not-open-after-update
software-center-wont-open
cant-open-software-center
But my problem doesn't seem to involve icons, rather:

$ software-center
Traceback (most recent call last):
  File "/usr/bin/software-center", line 25, in <module>
    from gi.repository import Gtk, GObject
  File "/usr/lib/python2.7/dist-packages/gi/importer.py", line 158, in     load_module
    introspection_module = get_introspection_module(namespace)
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 271, in get_introspection_module
    module = IntrospectionModule(namespace, version)
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 120, in __init__
repository.require(namespace, version)
gi.RepositoryError: Typelib file for namespace 'GdkPixbuf', version '2.0' not found

Question: Why aren't they lanuching, and how to fix it?

I installed synaptic and it works.

This might be connected to my solved problem: Trouble with APT, DPKG, SYNAPTIC. Linux-Image-thing

Any help is hot :)

  • This one ultimately worked for me: edit file: /usr/share/icons/default/index.theme and make sure "Inherits=" line includes icon theme that contains this missing iconm, eg: Inherits=elementary,Humanity – Seth Apr 11 '16 at 15:45
  • $ cat /usr/share/icons/default/index.theme [Icon Theme] Name=elementary Inherits=elementary,Humanity Still ain't launching. How do I know what theme is missing? – neb Apr 16 '16 at 9:10
1

The showed error message is about a namespace not found. Try to reinstall it:

sudo apt-get install --reinstall libgdk-pixbuf2.0-0
  • $ sudo apt-get install --reinstall gdk-pixbuf … Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package gdk-pixbuf – neb Apr 16 '16 at 9:06
  • Sorry, my fault. I've indicated the source package. – bitseater Apr 16 '16 at 10:20
  • No problem anymore. Heading for the VOID rather than the bloat… – neb Aug 6 '18 at 23:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.