1

(I was told by AskUbuntu to post my question here)

I have installed SQL Developer, which I need to execute by running
sudo /opt/sqldeveloper/sqldeveloper.sh

I made a custom .desktop file in /usr/share/applications with the following contents:

[Desktop Entry]
Name=SQLDeveloper
Comment=SQL Developer
Exec=sudo /opt/sqldeveloper/sqldeveloper.sh
Icon=/home/floris/Downloads/icon.png
StartupNotify=true
Terminal=true
Type=Application
Categories=Databases

Unfortunately, when I run this launcher - nothing happens. I have also tried using gksudo -k -u root but unsuccessful as well.

Anyone that can help me out? It's also worth mentioning that I am running Elementary OS Freya.

Thank you, in advance.

EDIT: If I right click on the launcher and select 'Run as root' the application works fine though...

1

If you don't need root privileges, try adding quotes and removing sudo, like:

Exec="/opt/sqldeveloper/sqldeveloper.sh"

However, if you need to run it in sudo, I don't know how to achieve that. Maybe create another script, to run your script, or something like that, idk.

0

Try deleting "sudo" in line:

Exec=sudo /opt/sqldeveloper/sqldeveloper.sh

  • thank you for your reply. Unfortunately nothing changes! – Cake Apr 9 '16 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.