1

I installed the openssh-server package but only want it to start on demand, as opposed to boot which is the package default.

When I tried to disable the SSH server using upstart I got the following output and warning

sudo update-rc.d ssh disable
update-rc.d: warning:  start runlevel arguments (none) do not match ssh 
Default-Start values (2 3 4 5)
System start/stop links for /etc/init.d/ssh do not exist.

Is this something to be concerned about? Should I be using another method? Best I can tell Freya is based on Ubuntu 14.04 which was still using upstart as the service management system.

1

It's not ssh, it's sshd.

sudo service sshd disable

  • On most systems you'd be correct about that, but apparently this is not the case on eOS seth@mm ~> service ssh status ssh stop/waiting seth@mm ~> service sshd status sshd: unrecognized service. Also this does not address the broader question at hand – Seth Apr 7 '16 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.