0

I installed rEFInd after GRUB2.Then I ran bcdedit /set {bootmgr} path \EFI\refind\shim.efi in Windows 10 and disabled secure boot to get it to boot into rEFInd.But when I booted into Windows 10 my laptop stopped booting rEFInd and would boot Windows 10.

Is there any way I can my HP laptop to permanently boot rEFInd

3
+50

I recommend that you first disable automatic boot repair from a console in Windows:

bcdedit /set {current} recoveryenabled No

Try now if that has solved your problem. If not, you may have to manually set rEFInd. I had to do it in my Dell pc following the instruccions in the rEFInd website, in the "Alternative Naming Options / Renaming Files Manually" section. I'll paste here the instructions:

  1. Access your ESP, as described in earlier sections.

  2. Look for an existing directory called EFI/BOOT or EFI/Microsoft/Boot. If neither of these directories exist, skip the next step. (Note that FAT is case-insensitive, so the name may vary in case.)

  3. Rename the existing directory or boot loader file to something else. For EFI/BOOT, try renaming it to EFI/Oldboot. For EFI/Microsoft/Boot, move or rename the bootmgfw.efi file it contains. For instance, you can move it to EFI/Microsoft. This will keep the boot loader accessible to rEFInd's menu, while preventing the firmware from launching it automatically.

  4. Rename/move your EFI/refind directory to EFI/BOOT. If you're working from EFI/Microsoft/Boot, you should move the contents of your rEFInd directory to EFI/Microsoft/Boot.

  5. Rename EFI/BOOT/refind_x64.efi to the name of the boot loader it's replacing—it should become EFI/BOOT/bootx64.efi or EFI/Microsoft/Boot/bootmgfw.efi.

If that sounds too complicated, and just as a plain-language summary (this may only be valid for some machines. If you don't find some of this directories or files, please read the website instructions):

  1. Access to /boot/efi
  2. Rename EFI/BOOT to EFI/Oldboot
  3. Move EFI/Microsoft/Boot/bootmgfw.efi to EFI/Microsoft/bootmgfw.efi
  4. Copy EFI/refind/* to EFI/Microsoft/Boot/* (* means all content)
  5. Rename EFI/Microsoft/Boot/refind_x64.efi to EFI/Microsoft/Boot/bootmgfw.efi
  6. Reboot
  • Yes, I tried this and it works but prevents fast boot from working – Suici Doga Apr 13 '16 at 1:26
  • Yes, that's a downside I had to pay too. Fast startup-enabled machines usually have trouble dual-booting with Linux, as Windows manages to skip the rEFInd boot manager [link]because the Windows kernel is loaded(howtogeek.com/243901/…) and ready to deliver a RAM-stored image. Also, be advised against trying to make modifications on a fast startup-enabled NTFS partition while on Linux, as it will end in [link]data loss(askubuntu.com/questions/452071/…). – derkomai Apr 13 '16 at 8:01
  • My Linux distribution does not mount fast boot partitions and instead gives a error saying to mount as read only.I reboot from Windows before I use Linux if I need to edit my NTFS data partition – Suici Doga Apr 13 '16 at 8:02
  • Yes, fast boot partitions are read only because any modifications made to the hiberfile will be inevitable lost. That's how fast startup works. Please refer to the second link in my previous comment.There you will find a good explaination. – derkomai Apr 13 '16 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.