A couple of days ago, I noticed blurry fonts in Steam. Now I think it may have something to do with Electron since GitKraken and Atom also have very blurry fonts to the point of being unusable. I have a multiple-monitor setup, but no high-dpi monitors. I already tried starting atom with --force-device-scale-factor=1 and --high-dpi-support=1


For some reason, my laptop, which uses the same versions of elementary OS and Atom, has crisp clear fonts. So, I'm trying to figure out where these systems differ (multi-monitor setup vs laptop screen). But right now I have no clue. Could be Electron, could be the graphic driver, could be anything.

Screenshots Atom Editor



  • 3
    I'm voting to close this question as off-topic because it's about a bug in electron and not about elementary OS or its included apps Apr 2, 2016 at 15:55
  • I am not sure it is a bug in electron, because the only bug report I could find for this problem also occurs on elementary OS github.com/atom/electron/issues/4984 Apr 2, 2016 at 16:08
  • Comments on the issue are indicating that it can also be reproduced in Arch and Windows. Electron is not a native toolkit to elementary OS. elementary does not provide or alter Electron in any way. Apr 2, 2016 at 16:34
  • I see. Well, it was worth a shot. I will follow the bug report at electron then. Thanks for your input. Apr 2, 2016 at 16:41

2 Answers 2


Solution: It was neither Electron nor Elementary OS but the Nvidia driver. All I had to do was disable FXAA Antialiasing in the antialiasing settings. Now everything is sharp again: Atom, GitKraken and even Steam. So, if you come across blurry fonts, follow these steps:

  • Open Nvidea X Server Settings
  • Go to X Screen 0 -> Antialiasing Settings
  • Remove the checkmark next to Enable FXAA

You only need to restart your applications, not your computer.

  • This worked for me! Also note that you need to restart X server after applying it. Dec 15, 2017 at 7:48

For what it's worth, I'm using Atom and Steam on Elementary OS with no problems. I have a FHD (1.5x) display, so initially both applications showed up with small (but sharp) text.

I bumped up the font size in Atom by add the following line to config.cson:


Incidentally, I don't think Steam uses Electron. Steam for Linux came out in February 2013. Atom (the application for which Electron was built) was announced in February 2014. Steam does use Chromium, though, so that may be the link between these three applications.

A few closed (but potentially relevant) issues on GitHub:

Finally, you could try updating Atom if you haven't already. Atom auto-updates on Windows and OS X but not Linux, which surprised me at first. I have to download a new .deb every time I want to upgrade Atom.

I know that's not an answer as such, but I hope it at least helps a little! :)

  • Thanks Ryan! I checked out your links, but unfortunately they don't fix my problem. It seems to be an issue either with electron or chromium and there is not much for me to do but to wait. Still, you were absolutely right and my version of atom was really outdated. Thanks for the tip! Apr 3, 2016 at 10:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.