2

Yesterday I got a new laptop and today I wanted to install Elementary OS on it.

In my first attempt of installing the OS (version 0.3.2, latest), after the first partitioning (manually, 1 swap partition and 1 root) I got an error of the GRUB:

Unable to install GRUB in /dev/sda Executing grub-install /dev/sda failed. This is a fatal error.

I couldn't fix this error so I decided to partitionate the disk in a different way. I chose the installation option "Erase disk and install Elementary OS". The installation began and just when GRUB installation was about to begin the screensaver turned on I suppose (the screen of my laptop turned off), then I moved the mouse, the screen turned on but in black and just showing the mouse pointer. I turned off the computer.

Then I tried to partitionate again manually, I clicked on create a new partition table and in the process my laptop "froze". I turned off again and here came the problems.

After that, my hard disk wasn't recognized in the BIOS. However, in "Try Elementary OS" I executed GParted and saw that the hard drive was recognized, but I also got this error:

"/dev/sda contains GPT signatures indicating that it has a GPT table, however..."

"The backup GPT table is corrupt, but the primary appears OK, so that will be used."

After trying to fix it with GParted, I used gdisks and fixparts. I created a new partition table. Then I rebooted and luckily the hard drive was recognized again in the BIOS. However GParted still gave me the same error. I tried again to install Elementary OS choosing the installation option "Erase disk and install Elementary OS" again, with logical volume management checked. Finally it worked.

QUESTIONS:

After the installation if I execute GParted from the hard drive OS it gives no error, but if I execute it from the USB ("Try Elementary OS") it still gives me the same error. Is this error important? Is the hard disk working properly?

My partition table looks like this: (image)

I can't see a swap partition, is it included in the elementaryos logical partition?

The GRUB menu doesn't show in the startup. Is this OK? (I have only Elementary OS installed with a non UEFI installation.)


This is the image:

Partitions

Thank you for your help.

  • I got a similar error.... Is your new computer a Lenovo ... because I can install elementary in any machine but with lenovo is a hard job, security issues with the hdd type. You can change it . – user12577 Oct 28 '17 at 17:46
1

I got this same error when I was not connected to the internet. Looks like it is a bug in the installer but it should install if you have a internet connection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.