1
  • I am not able to add user in System Settings /User Accounts
  • I have tried installing the gnome-system-tools as suggested in the other post (linked in the end of this post)
  • I am logged in with my default admin user account

I have unlocked the System Settings/User accounts locker

I can fill all fields out after clicking the + button

After finished no new account is visible in the list, nor on log in screen

How can I add a new user account?

System information: elementary OS 0.3.2 Freya 64-bit MacBook (installed)

Best Regards M Edvardsen

  • Does your Create User button ever light up blue like this? i.imgur.com/bLFLj5T.png – Lewis Goddard Mar 31 '16 at 17:15
  • Hi Lewis. Yes it does. I can create the account. But nothing seems to be created. Possibly in the "background" but not in the user list in gui and not on the login screen – sundfhs Mar 31 '16 at 20:26
  • tried terminal:--- cut -d: -f1 /etc/passwd the new user is not visible in the list either. Then tried: sudo adduser username system says something close to this: --- creates user "username" creates new group the_ same_ as_username (a number) creates new user "username" (a number) with group the_same_as_username useradd: existing lock file /etc/subuid.lock without a PID useradd: can not lock /etc/subuid; try again later. adduser: _"usr/sbin/useradd -d /home/_username_ -g _same as username_ -s /bin/bash -u _userid_ _username_" responded with error code 16. quits. – sundfhs Mar 31 '16 at 21:02
0

Try

groups youruser
sudo useradd newuser -m -G x-group,y-group,z-group

Option -G assigns newuser to x, y and z groups, option -m creates the home of newuser

sudo passwd newuser
  • groups youruser generates a message: groups: user youruser does not exist – sundfhs Apr 2 '16 at 17:19
  • sudo useradd youruser -m -g yourgroup generates following error code: useradd: existing lock file /etc/subuid.lock without a PID useradd: can't lock /etc/subuid; try again later – sundfhs Apr 2 '16 at 17:26
  • I reinstalled elementary os freya. Now it is working. – sundfhs Apr 3 '16 at 16:53
0

I reinstalled the OS. Now it is working

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.